CriticalFix available
libmad — security advisory
The mad_decoder_run() function in decoder.c in Underbit libmad through 0.15.1b allows remote attackers to cause a denial of service (SIGABRT because of double free or corruption) or possibly have unspecified other impact via a crafted file. NOTE: this may overlap CVE-2017-11552.
- Products
- libmad
- Affected versions
- Not specified
- Fixed versions
- 0.15.1b-r9
- CVEs
- CVE-2018-7263
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 22:16 UTC · Revision 1
Source evidence
The mad_decoder_run() function in decoder.c in Underbit libmad through 0.15.1b allows remote attackers to cause a denial of service (SIGABRT because of double free or corruption) or possibly have unspecified other impact via a crafted file. NOTE: this may overlap CVE-2017-11552.
osv:ALPINE-CVE-2018-7263
libmad
Fixed versions: 0.15.1b-r9
Complete source record
{
"id": "95b0e65b76eb358ee5884b5774db36c7b4325663b6861238ae7c07eab5721729",
"url": "https://osv.dev/vulnerability/ALPINE-CVE-2018-7263",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "ALPINE-CVE-2018-7263",
"summary": "The mad_decoder_run() function in decoder.c in Underbit libmad through 0.15.1b allows remote attackers to cause a denial of service (SIGABRT because of double free or corruption) or possibly have unspecified other impact via a crafted file. NOTE: this may overlap CVE-2017-11552.",
"evidence": "osv:ALPINE-CVE-2018-7263",
"products": [
{
"name": {
"value": "libmad",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.15.1b-r9",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "critical",
"structured": {
"id": "ALPINE-CVE-2018-7263",
"aliases": [
"ALPINE-CVE-2018-7263"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.15.1b-r9"
}
]
}
],
"package": {
"name": "libmad",
"purl": "pkg:apk/alpine/libmad?arch=source",
"ecosystem": "Alpine:v3.11"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2018-7263.json"
},
"ecosystem_specific": {}
}
],
"modified": "2026-10-23T17:24:49.955775103Z",
"provider": "osv",
"upstream": [
"CVE-2018-7263"
],
"references": [
"https://security.alpinelinux.org/vuln/CVE-2018-7263"
]
},
"related_cves": [
{
"value": "CVE-2018-7263",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 416158,
"published_at": "2018-02-20T21:29:00.333+00:00"
}