rust-lz4-flex — security advisory
lz4_flex is a pure Rust implementation of LZ4 compression/decompression. In versions 0.11.5 and below, and 0.12.0, decompressing invalid LZ4 data can leak sensitive information from uninitialized memory or from previous decompression operations. The library fails to properly validate offset values during LZ4 "match copy operations," allowing out-of-bounds reads from the output buffer. The block-based API functions (`decompress_into`, `decompress_into_with_dict`, and others when `safe-decode` is disabled) are affected, while all frame APIs are unaffected. The impact is potential exposure of sensitive data and secrets through crafted or malformed LZ4 input. This issue has been fixed in versions 0.11.6 and 0.12.1.
- Products
- rust-lz4-flex
- Affected versions
- 0.11.1-1, 0.11.3-1, 0.11.3-2, 0.13.0-1
- Fixed versions
- Not specified
- CVEs
- CVE-2026-32829
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 02:59 UTC · Revision 1
Source evidence
lz4_flex is a pure Rust implementation of LZ4 compression/decompression. In versions 0.11.5 and below, and 0.12.0, decompressing invalid LZ4 data can leak sensitive information from uninitialized memory or from previous decompression operations. The library fails to properly validate offset values during LZ4 "match copy operations," allowing out-of-bounds reads from the output buffer. The block-based API functions (`decompress_into`, `decompress_into_with_dict`, and others when `safe-decode` is disabled) are affected, while all frame APIs are unaffected. The impact is potential exposure of sensitive data and secrets through crafted or malformed LZ4 input. This issue has been fixed in versions 0.11.6 and 0.12.1.
osv:UBUNTU-CVE-2026-32829
rust-lz4-flex
Fixed versions: Not specified
rust-lz4-flex
Fixed versions: Not specified
rust-lz4-flex
Fixed versions: Not specified
rust-lz4-flex
Fixed versions: Not specified
Complete source record
{
"id": "6fada0839241a7f0a555c08fbb836d909663d7a37e2409226336fd8a9a17bc52",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2026-32829",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2026-32829",
"summary": "lz4_flex is a pure Rust implementation of LZ4 compression/decompression. In versions 0.11.5 and below, and 0.12.0, decompressing invalid LZ4 data can leak sensitive information from uninitialized memory or from previous decompression operations. The library fails to properly validate offset values during LZ4 \"match copy operations,\" allowing out-of-bounds reads from the output buffer. The block-based API functions (`decompress_into`, `decompress_into_with_dict`, and others when `safe-decode` is disabled) are affected, while all frame APIs are unaffected. The impact is potential exposure of sensitive data and secrets through crafted or malformed LZ4 input. This issue has been fixed in versions 0.11.6 and 0.12.1.",
"evidence": "osv:UBUNTU-CVE-2026-32829",
"products": [
{
"name": {
"value": "rust-lz4-flex",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "0.11.1-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "rust-lz4-flex",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "0.11.3-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "rust-lz4-flex",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "0.11.3-2",
"evidence": "/affected/2/versions"
},
{
"value": "0.13.0-1",
"evidence": "/affected/2/versions"
}
]
},
{
"name": {
"value": "rust-lz4-flex",
"evidence": "/affected/3/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "0.11.3-1",
"evidence": "/affected/3/versions"
},
{
"value": "0.11.3-2",
"evidence": "/affected/3/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "UBUNTU-CVE-2026-32829",
"aliases": [
"UBUNTU-CVE-2026-32829"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N"
},
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
},
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "rust-lz4-flex",
"purl": "pkg:deb/ubuntu/rust-lz4-flex?arch=source&distro=noble",
"ecosystem": "Ubuntu:24.04:LTS"
},
"versions": [
"0.11.1-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-32829.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "librust-lz4-flex-dev",
"binary_version": "0.11.1-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "rust-lz4-flex",
"purl": "pkg:deb/ubuntu/rust-lz4-flex?arch=source&distro=questing",
"ecosystem": "Ubuntu:25.10"
},
"versions": [
"0.11.3-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-32829.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "librust-lz4-flex-dev",
"binary_version": "0.11.3-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "rust-lz4-flex",
"purl": "pkg:deb/ubuntu/rust-lz4-flex?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"0.11.3-2",
"0.13.0-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-32829.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "librust-lz4-flex-dev",
"binary_version": "0.13.0-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "rust-lz4-flex",
"purl": "pkg:deb/ubuntu/rust-lz4-flex?arch=source&distro=resolute",
"ecosystem": "Ubuntu:26.04:LTS"
},
"versions": [
"0.11.3-1",
"0.11.3-2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-32829.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "librust-lz4-flex-dev",
"binary_version": "0.11.3-2"
}
]
}
}
],
"modified": "2026-10-17T12:59:58.370194880Z",
"provider": "osv",
"upstream": [
"CVE-2026-32829"
],
"references": [
"https://ubuntu.com/security/CVE-2026-32829",
"https://www.cve.org/CVERecord?id=CVE-2026-32829",
"https://rustsec.org/advisories/RUSTSEC-2026-0041.html",
"https://github.com/advisories/GHSA-vvp9-7p8x-rfvv"
]
},
"related_cves": [
{
"value": "CVE-2026-32829",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 360044,
"published_at": "2026-03-20T01:15:00+00:00"
}