WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting <= 1.13.1 - Authenticated (AccountingManager+) SQL Injection
The WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting plugin for WordPress is vulnerable to time-based SQL Injection via the id parameter in all versions up to, and including, 1.13.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with accounting manager or admin access, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-1173
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 04:44 UTC · Revision 1
Source evidence
WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting <= 1.13.1 - Authenticated (AccountingManager+) SQL Injection
core-osv · Original sourcePublished 2 May 2024, 16:52 UTC
The WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting plugin for WordPress is vulnerable to time-based SQL Injection via the id parameter in all versions up to, and including, 1.13.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with accounting manager or admin access, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
osv:CVE-2024-1173
Complete source record
{
"id": "f213b8d453780c5fa7b948b56046609e1fe490dd33906531b8e18656916bb7a2",
"url": "https://osv.dev/vulnerability/CVE-2024-1173",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting <= 1.13.1 - Authenticated (AccountingManager+) SQL Injection",
"summary": "The WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting plugin for WordPress is vulnerable to time-based SQL Injection via the id parameter in all versions up to, and including, 1.13.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with accounting manager or admin access, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.",
"evidence": "osv:CVE-2024-1173",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2024-1173",
"aliases": [
"CVE-2024-1173"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wp-erp/wp-erp",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "d17e53706fd521d5099f52d0841bce8a1ad83f82"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wedevs:wp_erp:*:*:*:*:free:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.13.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v1.13.1",
"v1.12.9",
"v1.12.8",
"v1.12.7",
"v1.12.6",
"v1.12.5",
"v1.12.3",
"v1.12.2",
"v1.12.1",
"v1.12.0",
"v1.11.3",
"v1.11.2",
"v1.11.1",
"v1.11.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-1173.json"
}
}
],
"modified": "2026-10-28T02:30:25.866404885Z",
"provider": "osv",
"references": [
"https://plugins.trac.wordpress.org/browser/erp/trunk/modules/accounting/includes/functions/people.php#L262",
"https://plugins.trac.wordpress.org/changeset/3071807/erp/trunk/modules/accounting/includes/functions/people.php",
"https://www.wordfence.com/threat-intel/vulnerabilities/id/94772de9-6ab8-45ff-8b56-19b50a81b66f?source=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/1xxx/CVE-2024-1173.json",
"https://nvd.nist.gov/vuln/detail/CVE-2024-1173"
],
"provider_metadata": {
"cwe_ids": [
"CWE-89"
],
"cna_assigner": "Wordfence",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "1.13.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/1xxx/CVE-2024-1173.json"
}
},
"related_cves": [
{
"value": "CVE-2024-1173",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 492560,
"published_at": "2024-05-02T16:52:26.03+00:00"
}