Apache HertzBeat (incubating): Jmx JNDI injection vulnerability
Improper Neutralization of Special Elements used in an LDAP Query ('LDAP Injection') vulnerability in Apache HertzBeat . The attacker needs to have an authenticated account with access, and the attack can only be triggered by crafting custom commands. A successful attack would result in arbitrary script execution. This issue affects Apache HertzBeat: through 1.7.2. Users are recommended to upgrade to version [1.7.3], which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-48208
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 17:00 UTC · Revision 1
Source evidence
Apache HertzBeat (incubating): Jmx JNDI injection vulnerability
core-osv · Original sourcePublished 9 Sept 2025, 09:31 UTC
Improper Neutralization of Special Elements used in an LDAP Query ('LDAP Injection') vulnerability in Apache HertzBeat . The attacker needs to have an authenticated account with access, and the attack can only be triggered by crafting custom commands. A successful attack would result in arbitrary script execution. This issue affects Apache HertzBeat: through 1.7.2. Users are recommended to upgrade to version [1.7.3], which fixes the issue.
osv:CVE-2025-48208
Complete source record
{
"id": "a4fc58884574ea9c4c7f7f4099738ff487ceb76caec2b757309878e07bf3fc45",
"url": "https://osv.dev/vulnerability/CVE-2025-48208",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache HertzBeat (incubating): Jmx JNDI injection vulnerability",
"summary": "Improper Neutralization of Special Elements used in an LDAP Query ('LDAP Injection') vulnerability in Apache HertzBeat . The attacker needs to have an authenticated account with access, and the attack can only be triggered by crafting custom commands. A successful attack would result in arbitrary script execution. This issue affects Apache HertzBeat: through 1.7.2. Users are recommended to upgrade to version [1.7.3], which fixes the issue.",
"evidence": "osv:CVE-2025-48208",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2025-48208",
"aliases": [
"CVE-2025-48208"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/hertzbeat",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "67ad4b04ef1b06b62f0e5030a26d0ca069294fa3"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:hertzbeat:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.7.3"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v1.7.2-rc1",
"v1.7.0",
"v1.6.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-48208.json"
}
}
],
"modified": "2026-10-28T02:30:51.108344218Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/48xxx/CVE-2025-48208.json",
"https://lists.apache.org/thread/3zrr3oo67pxxx7wgzj80kglltfshngn2",
"https://nvd.nist.gov/vuln/detail/CVE-2025-48208"
],
"provider_metadata": {
"cwe_ids": [
"CWE-90"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "1.7.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/48xxx/CVE-2025-48208.json"
}
},
"related_cves": [
{
"value": "CVE-2025-48208",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 519937,
"published_at": "2025-09-09T09:31:35.585+00:00"
}