ruby-doorkeeper — security advisory
Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS) vulnerability in web view's OAuth app form, user authorization prompt web view that can result in Stored XSS on the OAuth Client's name will cause users interacting with it will execute payload. This attack appear to be exploitable via The victim must be tricked to click an opaque link to the web view that runs the XSS payload. A malicious version virtually indistinguishable from a normal link.. This vulnerability appears to have been fixed in 4.2.6, 4.3.0.
- Products
- ruby-doorkeeper
- Affected versions
- Not specified
- Fixed versions
- 4.3.1-1
- CVEs
- CVE-2018-1000088
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 01:27 UTC · Revision 1
Source evidence
Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS) vulnerability in web view's OAuth app form, user authorization prompt web view that can result in Stored XSS on the OAuth Client's name will cause users interacting with it will execute payload. This attack appear to be exploitable via The victim must be tricked to click an opaque link to the web view that runs the XSS payload. A malicious version virtually indistinguishable from a normal link.. This vulnerability appears to have been fixed in 4.2.6, 4.3.0.
osv:DEBIAN-CVE-2018-1000088
ruby-doorkeeper
Fixed versions: 4.3.1-1
ruby-doorkeeper
Fixed versions: 4.3.1-1
ruby-doorkeeper
Fixed versions: 4.3.1-1
Complete source record
{
"id": "ba6eb7af4df39bd1a5311df5b317b4ed27ab3b0c8d3b05748d55aaef825ab5f3",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2018-1000088",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2018-1000088",
"summary": "Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS) vulnerability in web view's OAuth app form, user authorization prompt web view that can result in Stored XSS on the OAuth Client's name will cause users interacting with it will execute payload. This attack appear to be exploitable via The victim must be tricked to click an opaque link to the web view that runs the XSS payload. A malicious version virtually indistinguishable from a normal link.. This vulnerability appears to have been fixed in 4.2.6, 4.3.0.",
"evidence": "osv:DEBIAN-CVE-2018-1000088",
"products": [
{
"name": {
"value": "ruby-doorkeeper",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.3.1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ruby-doorkeeper",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.3.1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ruby-doorkeeper",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.3.1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2018-1000088",
"aliases": [
"DEBIAN-CVE-2018-1000088"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.3.1-1"
}
]
}
],
"package": {
"name": "ruby-doorkeeper",
"purl": "pkg:deb/debian/ruby-doorkeeper?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-1000088.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.3.1-1"
}
]
}
],
"package": {
"name": "ruby-doorkeeper",
"purl": "pkg:deb/debian/ruby-doorkeeper?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-1000088.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.3.1-1"
}
]
}
],
"package": {
"name": "ruby-doorkeeper",
"purl": "pkg:deb/debian/ruby-doorkeeper?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-1000088.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:04:46.295348461Z",
"provider": "osv",
"upstream": [
"CVE-2018-1000088"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2018-1000088"
]
},
"related_cves": [
{
"value": "CVE-2018-1000088",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 423649,
"published_at": "2018-03-13T15:29:01.3+00:00"
}