Medium
Security advisory
wp-includes/feed.php in WordPress before 4.9.1 does not properly restrict enclosures in RSS and Atom fields, which might allow attackers to conduct XSS attacks via a crafted URL.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2017-17094
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 08:50 UTC · Revision 1
Source evidence
wp-includes/feed.php in WordPress before 4.9.1 does not properly restrict enclosures in RSS and Atom fields, which might allow attackers to conduct XSS attacks via a crafted URL.
osv:CVE-2017-17094
Complete source record
{
"id": "ca1c12a579f11a929ecbc197a81d7775e1ecaecad155273cf0fe3b1a7de31a4b",
"url": "https://osv.dev/vulnerability/CVE-2017-17094",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2017-17094",
"summary": "wp-includes/feed.php in WordPress before 4.9.1 does not properly restrict enclosures in RSS and Atom fields, which might allow attackers to conduct XSS attacks via a crafted URL.",
"evidence": "osv:CVE-2017-17094",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2017-17094",
"aliases": [
"CVE-2017-17094"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wordpress/wordpress",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "fe24185f48a5fd27294c1251de7047c54fe178ca"
},
{
"fixed": "f1de7e42df29395c3314bf85bff3d1f4f90541de"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "4.9.1"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "f1de7e42df29395c3314bf85bff3d1f4f90541de"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-17094.json"
}
},
{
"ranges": [
{
"repo": "https://github.com/wordpress/wordpress-develop",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "4cffcde01100c98f81ade87865e51ff920e6a027"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "4.9.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-17094.json"
}
}
],
"modified": "2026-10-24T10:50:28.758929147Z",
"provider": "osv",
"references": [
"https://lists.debian.org/debian-lts-announce/2017/12/msg00019.html",
"https://wordpress.org/news/2017/11/wordpress-4-9-1-security-and-maintenance-release/",
"https://www.debian.org/security/2018/dsa-4090",
"https://codex.wordpress.org/Version_4.9.1",
"https://github.com/WordPress/WordPress/commit/f1de7e42df29395c3314bf85bff3d1f4f90541de",
"https://wpvulndb.com/vulnerabilities/8967"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "7.0"
},
{
"last_affected": "7.0"
},
{
"introduced": "8.0"
},
{
"last_affected": "8.0"
},
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2017-17094",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 442206,
"published_at": "2017-12-02T06:29:00.347+00:00"
}