Skip to content
Heist/ feed
Back to feed
High

CodeWhale rlm_eval before 0.8.64 Remote Code Execution

Type: advisorySources: OSV

CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool. The tool's approval_requirement() returns ApprovalRequirement::Auto, which the engine treats as 'never prompt,' causing arbitrary model-supplied Python code to run in a python3 interpreter without consulting the user's configured --approval-policy and without any approval prompt or audit step. An attacker can induce the agent to execute arbitrary code via prompt injection in untrusted content the agent reads (a web page, fetched URL, repository file, or MCP tool result); the companion rlm_open tool can stage such content. Code runs on the user's machine at the user's privilege level. Fixed in 0.8.64.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-75858
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 15:38 UTC · Revision 1

Source evidence

CodeWhale rlm_eval before 0.8.64 Remote Code Execution

core-osv · Original source

Published 18 Aug 2026, 15:21 UTC

CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool. The tool's approval_requirement() returns ApprovalRequirement::Auto, which the engine treats as 'never prompt,' causing arbitrary model-supplied Python code to run in a python3 interpreter without consulting the user's configured --approval-policy and without any approval prompt or audit step. An attacker can induce the agent to execute arbitrary code via prompt injection in untrusted content the agent reads (a web page, fetched URL, repository file, or MCP tool result); the companion rlm_open tool can stage such content. Code runs on the user's machine at the user's privilege level. Fixed in 0.8.64.

osv:CVE-2026-75858
Complete source record
{
  "id": "3022c199b611bcd5e984ec95d4e9198351aa2c7bae1df82d6cfde9b24b4e0358",
  "url": "https://osv.dev/vulnerability/CVE-2026-75858",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CodeWhale rlm_eval before 0.8.64 Remote Code Execution",
    "summary": "CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool. The tool's approval_requirement() returns ApprovalRequirement::Auto, which the engine treats as 'never prompt,' causing arbitrary model-supplied Python code to run in a python3 interpreter without consulting the user's configured --approval-policy and without any approval prompt or audit step. An attacker can induce the agent to execute arbitrary code via prompt injection in untrusted content the agent reads (a web page, fetched URL, repository file, or MCP tool result); the companion rlm_open tool can stage such content. Code runs on the user's machine at the user's privilege level. Fixed in 0.8.64.",
    "evidence": "osv:CVE-2026-75858",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2026-75858",
      "aliases": [
        "CVE-2026-75858",
        "GHSA-wrj3-vj8c-784f"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/codewhale-hq/Codewhale",
              "type": "GIT",
              "events": [
                {
                  "introduced": "81e4b93cc9df55de47489238078e255a563d044b"
                },
                {
                  "fixed": "5fa24733e9a1d11315506309b8edb0fdf2b94f04"
                },
                {
                  "introduced": "5fa24733e9a1d11315506309b8edb0fdf2b94f04"
                },
                {
                  "fixed": "9d2e6a89f58610d5f426ff26533a2bf312023790"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0.8.33"
                      },
                      {
                        "fixed": "0.8.41"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StandardRange"
                  },
                  {
                    "range": [
                      {
                        "introduced": "0.8.41"
                      },
                      {
                        "fixed": "0.8.64"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StandardRange"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v0.8.40",
            "v0.8.39",
            "v0.8.38",
            "v0.8.37",
            "v0.8.36",
            "v0.8.35",
            "v0.8.33"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-75858.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:30.068757877Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/75xxx/CVE-2026-75858.json",
        "https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-wrj3-vj8c-784f",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-75858",
        "https://www.vulncheck.com/advisories/codewhale-rlm-eval-before-remote-code-execution",
        "https://github.com/Hmbown/CodeWhale/commit/57f3c89471e27ac4032d9791f6885e5d4408c381"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-94"
        ],
        "cna_assigner": "VulnCheck",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/75xxx/CVE-2026-75858.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-75858",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 496903,
  "published_at": "2026-08-18T15:21:57.245+00:00"
}