cacti — security advisory
Cacti provides an operational monitoring and fault management framework. In versions 1.2.25 and prior, it is possible to execute arbitrary SQL code through the `pollers.php` script. An authorized user may be able to execute arbitrary SQL code. The vulnerable component is the `pollers.php`. Impact of the vulnerability - arbitrary SQL code execution. As of time of publication, a patch does not appear to exist.
- Products
- cacti
- Affected versions
- 1.2.24+ds1-1, 1.2.24+ds1-1+deb12u1
- Fixed versions
- 1.2.24+ds1-1+deb12u2, 1.2.26+ds1-1
- CVEs
- CVE-2023-49085
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 16:11 UTC · Revision 1
Source evidence
Cacti provides an operational monitoring and fault management framework. In versions 1.2.25 and prior, it is possible to execute arbitrary SQL code through the `pollers.php` script. An authorized user may be able to execute arbitrary SQL code. The vulnerable component is the `pollers.php`. Impact of the vulnerability - arbitrary SQL code execution. As of time of publication, a patch does not appear to exist.
osv:DEBIAN-CVE-2023-49085
cacti
Fixed versions: 1.2.24+ds1-1+deb12u2
cacti
Fixed versions: 1.2.26+ds1-1
cacti
Fixed versions: 1.2.26+ds1-1
Complete source record
{
"id": "fb38068dd5e99f11ec00fb71130ead65b1930e9f5517b10adf2a9793cb170fa6",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-49085",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-49085",
"summary": "Cacti provides an operational monitoring and fault management framework. In versions 1.2.25 and prior, it is possible to execute arbitrary SQL code through the `pollers.php` script. An authorized user may be able to execute arbitrary SQL code. The vulnerable component is the `pollers.php`. Impact of the vulnerability - arbitrary SQL code execution. As of time of publication, a patch does not appear to exist.",
"evidence": "osv:DEBIAN-CVE-2023-49085",
"products": [
{
"name": {
"value": "cacti",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.2.24+ds1-1+deb12u2",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "1.2.24+ds1-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.2.24+ds1-1+deb12u1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "cacti",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.2.26+ds1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "cacti",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.2.26+ds1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2023-49085",
"aliases": [
"DEBIAN-CVE-2023-49085"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.2.24+ds1-1+deb12u2"
}
]
}
],
"package": {
"name": "cacti",
"purl": "pkg:deb/debian/cacti?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"1.2.24+ds1-1",
"1.2.24+ds1-1+deb12u1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-49085.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.2.26+ds1-1"
}
]
}
],
"package": {
"name": "cacti",
"purl": "pkg:deb/debian/cacti?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-49085.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.2.26+ds1-1"
}
]
}
],
"package": {
"name": "cacti",
"purl": "pkg:deb/debian/cacti?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-49085.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T18:02:50.117925377Z",
"provider": "osv",
"upstream": [
"CVE-2023-49085"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-49085"
]
},
"related_cves": [
{
"value": "CVE-2023-49085",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 456950,
"published_at": "2023-12-22T17:15:07.99+00:00"
}