Skip to content
Heist/ feed
Back to feed
HighFix available

Payload: Polymorphic join queries could disclose hidden fields

Type: advisorySources: OSV

### Impact A user with query access could use polymorphic join filters to infer hidden or read-restricted field values, including password-reset tokens. You are affected if: - You use an affected Payload version. - Users can query a collection with a polymorphic join to sensitive fields. ### Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ### Workarounds There is no complete workaround. Restricting read access to sensitive collections reduces exposure but does not replace upgrading.

Products
payload
Affected versions
Not specified
Fixed versions
3.90.0, 4.0.0-canary.34
CVEs
CVE-2026-105847
Confirmed fixed CVEs
Not specified
Updated in this feed
27 Oct 2026, 12:12 UTC · Revision 1

Source evidence

Payload: Polymorphic join queries could disclose hidden fields

core-osv · Original source

Published 6 Oct 2026, 16:09 UTC

### Impact A user with query access could use polymorphic join filters to infer hidden or read-restricted field values, including password-reset tokens. You are affected if: - You use an affected Payload version. - Users can query a collection with a polymorphic join to sensitive fields. ### Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ### Workarounds There is no complete workaround. Restricting read access to sensitive collections reduces exposure but does not replace upgrading.

osv:GHSA-fpww-c55p-cjv6

payload

Fixed versions: 3.90.0

payload

Fixed versions: 4.0.0-canary.34

Complete source record
{
  "id": "6300e7821dcc858de8a7dada9e87db0084f800bb0d78c42ee311d6950a8e2490",
  "url": "https://osv.dev/vulnerability/GHSA-fpww-c55p-cjv6",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Payload: Polymorphic join queries could disclose hidden fields",
    "summary": "### Impact A user with query access could use polymorphic join filters to infer hidden or read-restricted field values, including password-reset tokens. You are affected if: - You use an affected Payload version. - Users can query a collection with a polymorphic join to sensitive fields. ### Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ### Workarounds There is no complete workaround. Restricting read access to sensitive collections reduces exposure but does not replace upgrading.",
    "evidence": "osv:GHSA-fpww-c55p-cjv6",
    "products": [
      {
        "name": {
          "value": "payload",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "3.90.0",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "payload",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4.0.0-canary.34",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "GHSA-fpww-c55p-cjv6",
      "aliases": [
        "CVE-2026-105847",
        "GHSA-fpww-c55p-cjv6"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "SEMVER",
              "events": [
                {
                  "introduced": "3.0.0"
                },
                {
                  "fixed": "3.90.0"
                }
              ]
            }
          ],
          "package": {
            "name": "payload",
            "purl": "pkg:npm/payload",
            "ecosystem": "npm"
          },
          "database_specific": {
            "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-fpww-c55p-cjv6/GHSA-fpww-c55p-cjv6.json"
          }
        },
        {
          "ranges": [
            {
              "type": "SEMVER",
              "events": [
                {
                  "introduced": "4.0.0-canary.0"
                },
                {
                  "fixed": "4.0.0-canary.34"
                }
              ]
            }
          ],
          "package": {
            "name": "payload",
            "purl": "pkg:npm/payload",
            "ecosystem": "npm"
          },
          "database_specific": {
            "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-fpww-c55p-cjv6/GHSA-fpww-c55p-cjv6.json"
          }
        }
      ],
      "modified": "2026-10-06T16:15:05.075692397Z",
      "provider": "osv",
      "references": [
        "https://github.com/payloadcms/payload/security/advisories/GHSA-fpww-c55p-cjv6",
        "https://github.com/payloadcms/payload/commit/caa3f69b5aecc6e7c2b459ed87972cbca9f33ee5",
        "https://github.com/payloadcms/payload",
        "https://github.com/payloadcms/payload/releases/tag/v3.90.0"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-200",
          "CWE-639"
        ],
        "severity": "HIGH",
        "github_reviewed": true,
        "nvd_published_at": null,
        "github_reviewed_at": "2026-10-06T16:09:04Z"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-105847",
        "evidence": "/aliases"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/database_specific/severity"
  },
  "source_id": "core-osv",
  "document_id": 89312,
  "published_at": "2026-10-06T16:09:04+00:00"
}