Skip to content
Heist/ feed
Back to feed
Medium

Raw exposure of database statements in Hyperterse MCP search tool

Type: advisorySources: OSV

Hyperterse is a tool-first MCP framework for building AI-ready backend surfaces from declarative config. Prior to v2.2.0, the search tool allows LLMs to search for tools using natural language. While returning results, Hyperterse also returned the raw SQL queries, exposing statements which were supposed to be executed under the hood, and protected from being displayed publicly. This issue has been fixed as of v2.2.0.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-31841
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 16:08 UTC · Revision 1

Source evidence

Raw exposure of database statements in Hyperterse MCP search tool

core-osv · Original source

Published 12 Mar 2026, 17:03 UTC

Hyperterse is a tool-first MCP framework for building AI-ready backend surfaces from declarative config. Prior to v2.2.0, the search tool allows LLMs to search for tools using natural language. While returning results, Hyperterse also returned the raw SQL queries, exposing statements which were supposed to be executed under the hood, and protected from being displayed publicly. This issue has been fixed as of v2.2.0.

osv:CVE-2026-31841
Complete source record
{
  "id": "ec224bf44feaa3583a5b3d0baf0805dfbb903ebd3ff9b7f69f4f0a8ab846d65c",
  "url": "https://osv.dev/vulnerability/CVE-2026-31841",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Raw exposure of database statements in Hyperterse MCP search tool",
    "summary": "Hyperterse is a tool-first MCP framework for building AI-ready backend surfaces from declarative config. Prior to v2.2.0, the search tool allows LLMs to search for tools using natural language. While returning results, Hyperterse also returned the raw SQL queries, exposing statements which were supposed to be executed under the hood, and protected from being displayed publicly. This issue has been fixed as of v2.2.0.",
    "evidence": "osv:CVE-2026-31841",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2026-31841",
      "aliases": [
        "CVE-2026-31841",
        "GHSA-92gp-jfgx-9qpv"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/hyperterse/hyperterse",
              "type": "GIT",
              "events": [
                {
                  "introduced": "6f82dd7f19c7aba7133ca19d8357ffa954cfe4a5"
                },
                {
                  "fixed": "884e99ac25e9c68e25a25a69548f63d64faf5ee3"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "2.0.0"
                      },
                      {
                        "fixed": "2.2.0"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "fixed": "884e99ac25e9c68e25a25a69548f63d64faf5ee3"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v2.2.0"
                  },
                  {
                    "cpe": "cpe:2.3:a:hyperterse:hyperterse:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.2.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v2.1.0",
            "v2.0.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-31841.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:30.200038722Z",
      "provider": "osv",
      "references": [
        "https://github.com/hyperterse/hyperterse/releases/tag/v2.2.0",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/31xxx/CVE-2026-31841.json",
        "https://github.com/hyperterse/hyperterse/security/advisories/GHSA-92gp-jfgx-9qpv",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-31841"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-433"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/31xxx/CVE-2026-31841.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-31841",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 497142,
  "published_at": "2026-03-12T17:03:32.818+00:00"
}