High
Security advisory
In Perl through 5.26.2, the Archive::Tar module allows remote attackers to bypass a directory-traversal protection mechanism, and overwrite arbitrary files, via an archive file containing a symlink and a regular file with the same name.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2018-12015
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 05:32 UTC · Revision 1
Source evidence
In Perl through 5.26.2, the Archive::Tar module allows remote attackers to bypass a directory-traversal protection mechanism, and overwrite arbitrary files, via an archive file containing a symlink and a regular file with the same name.
osv:CVE-2018-12015
Complete source record
{
"id": "2a1b5a01b2e46458c3da08eaea93be746f93a3325b16d4532ced81a1f1cf090f",
"url": "https://osv.dev/vulnerability/CVE-2018-12015",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2018-12015",
"summary": "In Perl through 5.26.2, the Archive::Tar module allows remote attackers to bypass a directory-traversal protection mechanism, and overwrite arbitrary files, via an archive file containing a symlink and a regular file with the same name.",
"evidence": "osv:CVE-2018-12015",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2018-12015",
"aliases": [
"CVE-2018-12015"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/perl/perl5",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"last_affected": "c5b1997939178730653db9e80f90cd53d722fe8d"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:perl:perl:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"last_affected": "5.26.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v5.26.2",
"v5.26.2-RC1",
"v5.26.1",
"v5.26.1-RC1",
"v5.26.0",
"v5.26.0-RC2",
"v5.25.11",
"v5.25.9",
"v5.25.7",
"v5.25.5",
"v5.25.4",
"v5.25.3",
"v5.24.0",
"v5.25.2",
"v5.25.0",
"v5.24.0-RC5",
"v5.24.0-RC4",
"v5.24.0-RC3",
"v5.24.0-RC2",
"v5.24.0-RC1",
"v5.23.7",
"v5.23.6",
"v5.23.4",
"v5.23.3",
"if-0.0605",
"v5.23.2",
"v5.23.1",
"v5.23.0",
"v5.22.0",
"v5.22.0-RC2",
"v5.22.0-RC1",
"v5.21.11",
"if-0.0604",
"v5.21.10",
"v5.21.9",
"v5.21.8",
"v5.21.6",
"v5.21.5",
"v5.21.4",
"v5.21.1",
"v5.21.0",
"v5.20.0",
"v5.20.0-RC1",
"v5.19.11",
"v5.19.7",
"v5.19.5",
"v5.19.3",
"v5.19.2",
"if-0.0603",
"v5.19.1",
"v5.18.0",
"v5.19.0",
"v5.18.0-RC4",
"v5.18.0-RC3",
"v5.18.0-RC2",
"v5.18.0-RC1",
"v5.17.9",
"v5.17.8",
"v5.17.7.0",
"v5.17.7",
"v5.17.6",
"v5.17.4",
"v5.17.2",
"v5.17.0",
"v5.16.0",
"v5.16.0-RC2",
"v5.16.0-RC1",
"v5.15.9",
"v5.15.5",
"v5.15.4",
"v5.15.3",
"v5.15.2",
"v5.15.1",
"v5.15.0",
"v5.14.0",
"v5.14.0-RC3",
"v5.14.0-RC2",
"v5.14.0-RC1",
"v5.13.11",
"v5.13.10",
"v5.13.9",
"v5.13.8",
"v5.13.7",
"v5.13.6",
"v5.13.5",
"v5.13.4",
"v5.13.3",
"v5.13.2",
"v5.13.1",
"v5.12.0",
"v5.13.0",
"v5.12.0-RC5",
"v5.12.0-RC4",
"v5.12.0-RC3",
"v5.12.0-RC2",
"v5.12.0-RC1",
"v5.12.0-RC0",
"v5.11.5",
"v5.11.4",
"v5.11.3",
"v5.11.1",
"v5.11.0",
"GitLive-blead",
"v5.10.0",
"perl-5.9.5",
"perl-5.9.4",
"perl-5.9.3",
"perl-5.9.2",
"perl-5.9.1",
"perl-5.9.0",
"perl-5.8.0",
"perl-5.7.3",
"perl-5.7.2",
"perl-5.7.1",
"perl-5.7.0",
"perl-5.6.0",
"perl-5.005",
"perl-5.003",
"perl-5.002_01",
"perl-5.002",
"perl-5.001n",
"perl-5.001",
"perl-5.000o",
"perl-5.000",
"perl-5a9",
"perl-5a2",
"perl-4.0.36",
"perl-4.0.00",
"perl-3.044",
"perl-3.000",
"perl-2.0",
"perl-1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-12015.json"
}
}
],
"modified": "2026-10-24T10:30:30.179592406Z",
"provider": "osv",
"references": [
"https://www.oracle.com/security-alerts/cpujul2020.html",
"https://access.redhat.com/errata/RHSA-2019:2097",
"https://seclists.org/bugtraq/2019/Mar/42",
"https://support.apple.com/kb/HT209600",
"https://usn.ubuntu.com/3684-1/",
"https://usn.ubuntu.com/3684-2/",
"https://www.debian.org/security/2018/dsa-4226",
"https://security.netapp.com/advisory/ntap-20180927-0001/",
"https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=900834"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:*"
],
"vendor_product": "apple:mac_os_x",
"extracted_events": [
{
"range": [
{
"fixed": "10.14.4"
}
],
"source": "CPE_RANGE"
}
]
},
{
"cpes": [
"cpe:2.3:a:archive\\:\\:tar_project:archive\\:\\:tar:*:*:*:*:*:perl:*:*"
],
"vendor_product": "archive::tar_project:archive::tar",
"extracted_events": [
{
"range": [
{
"last_affected": "2.28"
}
],
"source": "CPE_RANGE"
}
]
},
{
"cpes": [
"cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:*",
"cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:*",
"cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:*",
"cpe:2.3:o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:*",
"cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*"
],
"vendor_product": "canonical:ubuntu_linux",
"extracted_events": [
{
"range": [
{
"introduced": "12.04"
},
{
"last_affected": "12.04"
},
{
"introduced": "14.04"
},
{
"last_affected": "14.04"
},
{
"introduced": "16.04"
},
{
"last_affected": "16.04"
},
{
"introduced": "17.10"
},
{
"last_affected": "17.10"
},
{
"introduced": "18.04"
},
{
"last_affected": "18.04"
}
],
"source": "CPE_STRING"
}
]
},
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "8.0"
},
{
"last_affected": "8.0"
},
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2018-12015",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 432514,
"published_at": "2018-06-07T13:29:00.24+00:00"
}