jruby, ruby3.3 — security advisory
Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Prior to versions 0.4.24, 0.5.14, and 0.6.4, Net::IMAP::ResponseReader has quadratic time complexity when reading large responses containing many string literals. A hostile server can send responses which are crafted to exhaust the client's CPU for a denial of service attack. This issue has been patched in versions 0.4.24, 0.5.14, and 0.6.4.
- Products
- jruby, ruby3.3
- Affected versions
- 3.3.7-1ubuntu2, 3.3.8-2.2ubuntu4, 3.3.8-2ubuntu1, 3.3.8-2ubuntu2, 3.3.8-2ubuntu2.1, 3.3.8-2ubuntu3, 9.4.14.0+ds-1, 9.4.8.0+ds-2ubuntu1, 9.4.8.0+ds-3ubuntu1
- Fixed versions
- Not specified
- CVEs
- CVE-2026-42245
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 02:11 UTC · Revision 1
Source evidence
Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Prior to versions 0.4.24, 0.5.14, and 0.6.4, Net::IMAP::ResponseReader has quadratic time complexity when reading large responses containing many string literals. A hostile server can send responses which are crafted to exhaust the client's CPU for a denial of service attack. This issue has been patched in versions 0.4.24, 0.5.14, and 0.6.4.
osv:UBUNTU-CVE-2026-42245
jruby
Fixed versions: Not specified
ruby3.3
Fixed versions: Not specified
jruby
Fixed versions: Not specified
ruby3.3
Fixed versions: Not specified
Complete source record
{
"id": "a5af8358a9e8472dd7c27e362a0e28a710ff0ef71ad564f62d646234b8fc5ff2",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2026-42245",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2026-42245",
"summary": "Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Prior to versions 0.4.24, 0.5.14, and 0.6.4, Net::IMAP::ResponseReader has quadratic time complexity when reading large responses containing many string literals. A hostile server can send responses which are crafted to exhaust the client's CPU for a denial of service attack. This issue has been patched in versions 0.4.24, 0.5.14, and 0.6.4.",
"evidence": "osv:UBUNTU-CVE-2026-42245",
"products": [
{
"name": {
"value": "jruby",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "9.4.8.0+ds-2ubuntu1",
"evidence": "/affected/0/versions"
},
{
"value": "9.4.8.0+ds-3ubuntu1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "ruby3.3",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "3.3.7-1ubuntu2",
"evidence": "/affected/1/versions"
},
{
"value": "3.3.8-2ubuntu1",
"evidence": "/affected/1/versions"
},
{
"value": "3.3.8-2ubuntu2",
"evidence": "/affected/1/versions"
},
{
"value": "3.3.8-2ubuntu2.1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "jruby",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "9.4.8.0+ds-3ubuntu1",
"evidence": "/affected/2/versions"
},
{
"value": "9.4.14.0+ds-1",
"evidence": "/affected/2/versions"
}
]
},
{
"name": {
"value": "ruby3.3",
"evidence": "/affected/3/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "3.3.8-2ubuntu3",
"evidence": "/affected/3/versions"
},
{
"value": "3.3.8-2.2ubuntu4",
"evidence": "/affected/3/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "UBUNTU-CVE-2026-42245",
"aliases": [
"UBUNTU-CVE-2026-42245"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N"
},
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "jruby",
"purl": "pkg:deb/ubuntu/jruby?arch=source&distro=questing",
"ecosystem": "Ubuntu:25.10"
},
"versions": [
"9.4.8.0+ds-2ubuntu1",
"9.4.8.0+ds-3ubuntu1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-42245.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "jruby",
"binary_version": "9.4.8.0+ds-3ubuntu1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "ruby3.3",
"purl": "pkg:deb/ubuntu/ruby3.3?arch=source&distro=questing",
"ecosystem": "Ubuntu:25.10"
},
"versions": [
"3.3.7-1ubuntu2",
"3.3.8-2ubuntu1",
"3.3.8-2ubuntu2",
"3.3.8-2ubuntu2.1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-42245.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libruby3.3",
"binary_version": "3.3.8-2ubuntu2.1"
},
{
"binary_name": "ruby3.3",
"binary_version": "3.3.8-2ubuntu2.1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "jruby",
"purl": "pkg:deb/ubuntu/jruby?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"9.4.8.0+ds-3ubuntu1",
"9.4.14.0+ds-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-42245.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "jruby",
"binary_version": "9.4.14.0+ds-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "ruby3.3",
"purl": "pkg:deb/ubuntu/ruby3.3?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"3.3.8-2ubuntu3",
"3.3.8-2.2ubuntu4"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-42245.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libruby3.3",
"binary_version": "3.3.8-2.2ubuntu4"
},
{
"binary_name": "ruby3.3",
"binary_version": "3.3.8-2.2ubuntu4"
}
]
}
}
],
"modified": "2026-10-17T12:58:16.106467616Z",
"provider": "osv",
"upstream": [
"CVE-2026-42245"
],
"references": [
"https://ubuntu.com/security/CVE-2026-42245",
"https://www.cve.org/CVERecord?id=CVE-2026-42245",
"https://github.com/ruby/net-imap/commit/6091f7d6b1f3514cafbfe39c76f2b5d73de3ca96",
"https://github.com/ruby/net-imap/commit/88d95231fc8afef11c1f074453f7d75b68c9dfda",
"https://github.com/ruby/net-imap/commit/de685f91a4a4cc75eb80da898c2bf8af08d34819",
"https://github.com/ruby/net-imap/releases/tag/v0.4.24",
"https://github.com/ruby/net-imap/releases/tag/v0.5.14",
"https://github.com/ruby/net-imap/releases/tag/v0.6.4",
"https://github.com/ruby/net-imap/security/advisories/GHSA-q2mw-fvj9-vvcw"
]
},
"related_cves": [
{
"value": "CVE-2026-42245",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/1/score"
},
"source_id": "core-osv",
"document_id": 358478,
"published_at": "2026-05-09T20:16:00+00:00"
}