Security advisory
PhpFastCache is a high-performance backend cache system (packagist package phpfastcache/phpfastcache). In versions before 6.1.5, 7.1.2, and 8.0.7 the `phpinfo()` can be exposed if the `/vendor` is not protected from public access. This is a rare situation today since the vendor directory is often located outside the web directory or protected via server rule (.htaccess, etc). Only the v6, v7 and v8 will be patched respectively in 8.0.7, 7.1.2, 6.1.5. Older versions such as v5, v4 are not longer supported and will **NOT** be patched. As a workaround, protect the `/vendor` directory from public access.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-37704
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:51 UTC · Revision 1
Source evidence
PhpFastCache is a high-performance backend cache system (packagist package phpfastcache/phpfastcache). In versions before 6.1.5, 7.1.2, and 8.0.7 the `phpinfo()` can be exposed if the `/vendor` is not protected from public access. This is a rare situation today since the vendor directory is often located outside the web directory or protected via server rule (.htaccess, etc). Only the v6, v7 and v8 will be patched respectively in 8.0.7, 7.1.2, 6.1.5. Older versions such as v5, v4 are not longer supported and will **NOT** be patched. As a workaround, protect the `/vendor` directory from public access.
osv:CVE-2021-37704
Complete source record
{
"id": "24ac0fa4485c2886f2e982f1e8a9103e90b075981548c467bf8b001154c81631",
"url": "https://osv.dev/vulnerability/CVE-2021-37704",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-37704",
"summary": "PhpFastCache is a high-performance backend cache system (packagist package phpfastcache/phpfastcache). In versions before 6.1.5, 7.1.2, and 8.0.7 the `phpinfo()` can be exposed if the `/vendor` is not protected from public access. This is a rare situation today since the vendor directory is often located outside the web directory or protected via server rule (.htaccess, etc). Only the v6, v7 and v8 will be patched respectively in 8.0.7, 7.1.2, 6.1.5. Older versions such as v5, v4 are not longer supported and will **NOT** be patched. As a workaround, protect the `/vendor` directory from public access.",
"evidence": "osv:CVE-2021-37704",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2021-37704",
"aliases": [
"CVE-2021-37704",
"GHSA-cvh5-p6r6-g2qc"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/TruCopilot/phpfastcache",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "cab4e79f1ad353302c82d7b73de0aa4b6b00144c"
},
{
"introduced": "307a378f917ebd2c397638e6cd56b7f64c2a2c16"
},
{
"fixed": "ee5e7fc730aeef7b0e0970adc038168b4087601c"
},
{
"introduced": "7e2d1e10d08d4b25251dc0c0d9e7936709dcce9f"
},
{
"fixed": "60f7124532d29d273c989603bdfec891a3e71948"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:phpfastcache:phpfastcache:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "6.1.5"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:phpfastcache:phpfastcache:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "7.0.0"
},
{
"fixed": "7.1.2"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:phpfastcache:phpfastcache:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "8.0.0"
},
{
"fixed": "8.0.7"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"8.0.4",
"8.0.3",
"8.0.2",
"8.0.1",
"7.1.0",
"7.0.5",
"7.0.4",
"7.0.3",
"7.0.2",
"7.0.1",
"7.0.0",
"6.1.1",
"6.1.0",
"6.0.8",
"5.0.10",
"4.0.15",
"4.0.14",
"4.0.13",
"4.0.12",
"4.0.11",
"4.0.10",
"4.0.9",
"4.0.8",
"4.0.7",
"4.0.6",
"4.0.5",
"4.0.4",
"4.0.3-beta1",
"4.0.3",
"4.0.2beta1",
"4.0.2-beta1",
"4.0.2",
"3.0.5",
"3.0.4",
"3.0.3",
"3.0.2",
"3.0.1",
"2.4.2"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-37704.json"
}
},
{
"ranges": [
{
"repo": "https://github.com/trucopilot/phpfastcache",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "41a77d0d8f126dbd6fbedcd9e6a82e86cdaafa51"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"fixed": "41a77d0d8f126dbd6fbedcd9e6a82e86cdaafa51"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"8.0.6",
"8.0.5",
"8.0.4",
"8.0.3",
"8.0.2",
"8.0.1",
"7.1.0",
"7.0.5",
"7.0.4",
"7.0.3",
"7.0.2",
"7.0.1",
"7.0.0",
"7.0.0-RC4",
"7.0.0-RC3",
"7.0.0-RC2",
"7.0.0-RC",
"7.0.0-beta3",
"7.0.0-beta2",
"7.0.0-beta",
"7.0.0-alpha3",
"7.0.0-alpha2",
"7.0.0-alpha",
"5.0.10",
"4.0.15",
"4.0.14",
"4.0.13",
"4.0.12",
"4.0.11",
"4.0.10",
"4.0.9",
"4.0.8",
"4.0.7",
"4.0.6",
"4.0.5",
"4.0.4",
"4.0.3-beta1",
"4.0.3",
"4.0.2beta1",
"4.0.2-beta1",
"4.0.2",
"3.0.5",
"3.0.4",
"3.0.3",
"3.0.2",
"3.0.1",
"2.4.2"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-37704.json"
}
}
],
"modified": "2026-10-20T10:54:50.175810170Z",
"provider": "osv",
"references": [
"https://github.com/PHPSocialNetwork/phpfastcache/blob/master/CHANGELOG.md#807",
"https://github.com/PHPSocialNetwork/phpfastcache/pull/814",
"https://github.com/PHPSocialNetwork/phpfastcache/pull/815",
"https://github.com/PHPSocialNetwork/phpfastcache/security/advisories/GHSA-cvh5-p6r6-g2qc",
"https://packagist.org/packages/phpfastcache/phpfastcache",
"https://github.com/flextype/flextype/issues/567",
"https://github.com/PHPSocialNetwork/phpfastcache/commit/41a77d0d8f126dbd6fbedcd9e6a82e86cdaafa51",
"https://github.com/PHPSocialNetwork/phpfastcache/pull/813"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-37704",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 386241,
"published_at": "2021-08-12T20:15:07.267+00:00"
}