Skip to content
Heist/ feed
Back to feed
Low

Possible XSS vulnerability with certain configurations of rails-html-sanitizer 1.6.0

Type: advisorySources: OSV

rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. There is a possible XSS vulnerability with certain configurations of Rails::HTML::Sanitizer 1.6.0 when used with Rails >= 7.1.0. A possible XSS vulnerability with certain configurations of Rails::HTML::Sanitizer may allow an attacker to inject content if HTML5 sanitization is enabled and the application developer has overridden the sanitizer's allowed tags where the "math", "mtext", "table", and "style" elements are allowed and either either "mglyph" or "malignmark" are allowed. This vulnerability is fixed in 1.6.1.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-53988
Confirmed fixed CVEs
Not specified
Updated in this feed
8 Nov 2026, 01:06 UTC · Revision 1

Source evidence

Possible XSS vulnerability with certain configurations of rails-html-sanitizer 1.6.0

core-osv · Original source

Published 2 Dec 2024, 21:09 UTC

rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. There is a possible XSS vulnerability with certain configurations of Rails::HTML::Sanitizer 1.6.0 when used with Rails >= 7.1.0. A possible XSS vulnerability with certain configurations of Rails::HTML::Sanitizer may allow an attacker to inject content if HTML5 sanitization is enabled and the application developer has overridden the sanitizer's allowed tags where the "math", "mtext", "table", and "style" elements are allowed and either either "mglyph" or "malignmark" are allowed. This vulnerability is fixed in 1.6.1.

osv:CVE-2024-53988
Complete source record
{
  "id": "f11d791e26e1f54917f29bbd0036903f4a54fe763c888d16b7f81c4a1c8c6217",
  "url": "https://osv.dev/vulnerability/CVE-2024-53988",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Possible XSS vulnerability with certain configurations of rails-html-sanitizer 1.6.0",
    "summary": "rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. There is a possible XSS vulnerability with certain configurations of Rails::HTML::Sanitizer 1.6.0 when used with Rails >= 7.1.0. A possible XSS vulnerability with certain configurations of Rails::HTML::Sanitizer may allow an attacker to inject content if HTML5 sanitization is enabled and the application developer has overridden the sanitizer's allowed tags where the \"math\", \"mtext\", \"table\", and \"style\" elements are allowed and either either \"mglyph\" or \"malignmark\" are allowed. This vulnerability is fixed in 1.6.1.",
    "evidence": "osv:CVE-2024-53988",
    "products": [],
    "severity": "low",
    "structured": {
      "id": "CVE-2024-53988",
      "aliases": [
        "CVE-2024-53988",
        "GHSA-cfjx-w229-hgx5"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/rails/rails-html-sanitizer",
              "type": "GIT",
              "events": [
                {
                  "introduced": "19fd6cd66f31316642e758bf01a410f3fd128f42"
                },
                {
                  "fixed": "5e96b19bbb934284e675109851bd82429622bb6e"
                },
                {
                  "fixed": "a0a3e8b76b696446ffc6bffcff3bc7b7c6393c72"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "1.6.0"
                      },
                      {
                        "fixed": "1.6.1"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "fixed": "a0a3e8b76b696446ffc6bffcff3bc7b7c6393c72"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.6.0",
            "v1.6.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-53988.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:52.479675490Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/53xxx/CVE-2024-53988.json",
        "https://github.com/rails/rails-html-sanitizer/security/advisories/GHSA-cfjx-w229-hgx5",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-53988",
        "https://github.com/rails/rails-html-sanitizer/commit/a0a3e8b76b696446ffc6bffcff3bc7b7c6393c72"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/53xxx/CVE-2024-53988.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-53988",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 521200,
  "published_at": "2024-12-02T21:09:56.44+00:00"
}