Skip to content
Heist/ feed
Back to feed
High

Activity Log – Monitor & Record User Changes <= 2.11.1 - Unauthenticated Stored Cross-Site Scripting via Event Context

Type: advisorySources: OSV

The Activity Log – Monitor & Record User Changes plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the event parameters in all versions up to, and including, 2.11.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever an administrative user accesses an injected page.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-10788
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 16:28 UTC · Revision 1

Source evidence

Activity Log – Monitor & Record User Changes <= 2.11.1 - Unauthenticated Stored Cross-Site Scripting via Event Context

core-osv · Original source

Published 21 Nov 2024, 05:33 UTC

The Activity Log – Monitor & Record User Changes plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the event parameters in all versions up to, and including, 2.11.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever an administrative user accesses an injected page.

osv:CVE-2024-10788
Complete source record
{
  "id": "c9a1e42a2c62d2e2f5b61e1fe6099b51d836d2899f5216a20cd95e703f8b5d04",
  "url": "https://osv.dev/vulnerability/CVE-2024-10788",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Activity Log – Monitor & Record User Changes <= 2.11.1 - Unauthenticated Stored Cross-Site Scripting via Event Context",
    "summary": "The Activity Log – Monitor & Record User Changes plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the event parameters in all versions up to, and including, 2.11.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever an administrative user accesses an injected page.",
    "evidence": "osv:CVE-2024-10788",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2024-10788",
      "aliases": [
        "CVE-2024-10788"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/elementor/activity-log",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "f75ee2a477ca459a5054014904bca7c97f4ea93e"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:pojo:activity_log:*:*:*:*:*:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.11.2"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "2.11.1",
            "2.11.0",
            "2.10.1",
            "2.10.0",
            "2.9.2",
            "2.9.1",
            "2.9.0",
            "2.8.9",
            "2.8.8",
            "2.8.6",
            "2.8.5",
            "2.8.4",
            "2.8.1",
            "2.8.0",
            "2.7.0",
            "2.6.0",
            "2.5.2",
            "2.5.1",
            "2.5.0",
            "2.4.1",
            "2.4.0",
            "2.3.6",
            "2.3.5",
            "2.3.4",
            "2.3.3",
            "2.3.2",
            "2.3.1",
            "2.2.12",
            "2.2.11",
            "2.2.10",
            "2.2.9",
            "2.2.8",
            "2.2.7",
            "2.2.6",
            "2.2.5",
            "2.2.4",
            "2.2.3",
            "2.2.2",
            "2.2.1",
            "2.2.0",
            "2.1.16",
            "2.1.15",
            "2.1.14",
            "2.1.13",
            "2.1.12",
            "2.1.11",
            "2.1.10",
            "2.1.9",
            "2.1.8",
            "2.1.7",
            "2.1.6",
            "2.1.5",
            "2.1.4",
            "v2.1.3",
            "v2.1.2",
            "v2.1.1",
            "v2.1.4",
            "v2.1.0",
            "v2.0.7",
            "v2.0.6",
            "v2.0.5",
            "v2.0.4",
            "v2.0.3",
            "v2.0.2",
            "v2.0.0",
            "v2.0.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-10788.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:30.392892936Z",
      "provider": "osv",
      "references": [
        "https://plugins.trac.wordpress.org/browser/aryo-activity-log/tags/2.11.0/hooks/class-aal-hook-themes.php#L18",
        "https://plugins.trac.wordpress.org/browser/aryo-activity-log/tags/2.11.0/hooks/class-aal-hook-themes.php#L21",
        "https://www.wordfence.com/threat-intel/vulnerabilities/id/75324bf1-a00e-4da7-8d42-d224c39ceb79?source=cve",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/10xxx/CVE-2024-10788.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-10788"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "Wordfence",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "last_affected": "2.11.1"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/10xxx/CVE-2024-10788.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-10788",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 497359,
  "published_at": "2024-11-21T05:33:50.411+00:00"
}