HighFix available
node-css-what — security advisory
The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.
- Products
- node-css-what
- Affected versions
- Not specified
- Fixed versions
- 5.0.1-1
- CVEs
- CVE-2022-21222
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:35 UTC · Revision 1
Source evidence
The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.
osv:DEBIAN-CVE-2022-21222
node-css-what
Fixed versions: 5.0.1-1
node-css-what
Fixed versions: 5.0.1-1
node-css-what
Fixed versions: 5.0.1-1
Complete source record
{
"id": "93a47c8133751327e129157a0a563ece6bcec2cd6db8a90f83b8a20f35099d4c",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-21222",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-21222",
"summary": "The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.",
"evidence": "osv:DEBIAN-CVE-2022-21222",
"products": [
{
"name": {
"value": "node-css-what",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.0.1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "node-css-what",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.0.1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "node-css-what",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.0.1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-21222",
"aliases": [
"DEBIAN-CVE-2022-21222"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.0.1-1"
}
]
}
],
"package": {
"name": "node-css-what",
"purl": "pkg:deb/debian/node-css-what?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-21222.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.0.1-1"
}
]
}
],
"package": {
"name": "node-css-what",
"purl": "pkg:deb/debian/node-css-what?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-21222.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.0.1-1"
}
]
}
],
"package": {
"name": "node-css-what",
"purl": "pkg:deb/debian/node-css-what?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-21222.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:00:44.731492718Z",
"provider": "osv",
"upstream": [
"CVE-2022-21222"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-21222"
]
},
"related_cves": [
{
"value": "CVE-2022-21222",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 322628,
"published_at": "2022-09-30T05:15:08.713+00:00"
}