Skip to content
Heist/ feed
Back to feed
Medium

WordPress Cooked Plugin - Cross-Site Request Forgery to Get Recipe IDs

Type: advisorySources: OSV

Cooked is a recipe plugin for WordPress. The Cooked plugin is vulnerable to Cross-Site Request Forgery (CSRF) in versions up to, and including, 1.7.15.4 due to missing or incorrect nonce validation on the AJAX action handler. This vulnerability could allow an attacker to trick users into performing an action they didn't intend to perform under their current authentication. This issue has been addressed in release version 1.8.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-39678
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 13:46 UTC · Revision 1

Source evidence

WordPress Cooked Plugin - Cross-Site Request Forgery to Get Recipe IDs

core-osv · Original source

Published 17 Jul 2024, 23:43 UTC

Cooked is a recipe plugin for WordPress. The Cooked plugin is vulnerable to Cross-Site Request Forgery (CSRF) in versions up to, and including, 1.7.15.4 due to missing or incorrect nonce validation on the AJAX action handler. This vulnerability could allow an attacker to trick users into performing an action they didn't intend to perform under their current authentication. This issue has been addressed in release version 1.8.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

osv:CVE-2024-39678
Complete source record
{
  "id": "005d3bd0cc13ddbf8946f274136596990718ca3e9910c985d170a9a68e864af3",
  "url": "https://osv.dev/vulnerability/CVE-2024-39678",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "WordPress Cooked Plugin - Cross-Site Request Forgery to Get Recipe IDs",
    "summary": "Cooked is a recipe plugin for WordPress. The Cooked plugin is vulnerable to Cross-Site Request Forgery (CSRF) in versions up to, and including, 1.7.15.4 due to missing or incorrect nonce validation on the AJAX action handler. This vulnerability could allow an attacker to trick users into performing an action they didn't intend to perform under their current authentication. This issue has been addressed in release version 1.8.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.",
    "evidence": "osv:CVE-2024-39678",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2024-39678",
      "aliases": [
        "CVE-2024-39678",
        "GHSA-pp3h-ghxf-r9pc"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/xjsv/cooked",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "b1d5b5bd17a56534118c1c2609b1b88d13233cf5"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.8.0"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "cpe": "cpe:2.3:a:boxystudio:cooked:*:*:*:*:pro:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.8.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v1.7.15.4",
            "v1.7.15.3",
            "v1.7.15.2",
            "v1.7.14"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-39678.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:35.930358850Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/39xxx/CVE-2024-39678.json",
        "https://github.com/XjSv/Cooked/security/advisories/GHSA-pp3h-ghxf-r9pc",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-39678"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-352"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/39xxx/CVE-2024-39678.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-39678",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 503283,
  "published_at": "2024-07-17T23:43:32.484+00:00"
}