Skip to content
Heist/ feed
Back to feed
Medium

FPDI: Memory Exhaustion and Endless Loop in FPDI leads to Denial of Service

Type: advisorySources: OSV

FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. Prior to version 2.6.7, an attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion or a script time-out. Repeated attacks can lead to sustained service unavailability. This issue has been patched in version 2.6.7.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-45802
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 20:29 UTC · Revision 1

Source evidence

FPDI: Memory Exhaustion and Endless Loop in FPDI leads to Denial of Service

core-osv · Original source

Published 11 Jun 2026, 18:59 UTC

FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. Prior to version 2.6.7, an attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion or a script time-out. Repeated attacks can lead to sustained service unavailability. This issue has been patched in version 2.6.7.

osv:CVE-2026-45802
Complete source record
{
  "id": "5dd41b7d19fec2ee576c75d911494f6d805a6583122dbd4fcb57040ff370b139",
  "url": "https://osv.dev/vulnerability/CVE-2026-45802",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "FPDI: Memory Exhaustion and Endless Loop in FPDI leads to Denial of Service",
    "summary": "FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. Prior to version 2.6.7, an attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion or a script time-out. Repeated attacks can lead to sustained service unavailability. This issue has been patched in version 2.6.7.",
    "evidence": "osv:CVE-2026-45802",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2026-45802",
      "aliases": [
        "CVE-2026-45802",
        "GHSA-2mgw-7q6p-8grg"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/setasign/fpdi",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "388c51e69982a3fc16698710b763e8107a49f510"
                },
                {
                  "fixed": "1695cfcc7e01fe844a7296b3de90855a3fa65be6"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.6.7"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "fixed": "1695cfcc7e01fe844a7296b3de90855a3fa65be6"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "388c51e69982a3fc16698710b763e8107a49f510"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v2.6.7"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v2.6.6",
            "v2.6.5",
            "v2.6.4",
            "v2.6.3",
            "v2.6.2",
            "v2.6.1",
            "v2.6.0",
            "v2.5.0",
            "v2.4.1",
            "v2.4.0",
            "v2.3.7",
            "v2.3.6",
            "v2.3.5",
            "v2.3.4",
            "v2.3.3",
            "v2.3.2",
            "v2.3.1",
            "v2.3.0",
            "v2.2.0",
            "v2.1.1",
            "v2.1.0",
            "v2.0.3",
            "v2.0.2",
            "v2.0.1",
            "v2.0.0",
            "1.6.2",
            "1.6.1",
            "1.6.0",
            "1.5.4",
            "1.5.3",
            "1.5.2"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-45802.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:51.734009583Z",
      "provider": "osv",
      "references": [
        "https://github.com/Setasign/FPDI/releases/tag/v2.6.7",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/45xxx/CVE-2026-45802.json",
        "https://github.com/Setasign/FPDI/security/advisories/GHSA-2mgw-7q6p-8grg",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-45802",
        "https://github.com/Setasign/FPDI/commit/1695cfcc7e01fe844a7296b3de90855a3fa65be6"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-400",
          "CWE-770"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/45xxx/CVE-2026-45802.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-45802",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 520314,
  "published_at": "2026-06-11T18:59:36.226+00:00"
}