Skip to content
Heist/ feed
Back to feed
High

Remote code execution vulnerabilities in MediaCMS

Type: advisorySources: OSV

MediaCMS is an open source video and media CMS, written in Python/Django and React, featuring a REST API. MediaCMS has been prone to vulnerabilities that upon special cases can lead to remote code execution. All versions before v4.1.0 are susceptible, and users are highly recommended to upgrade. The vulnerabilities are related with insufficient input validation while uploading media content. The condition to exploit the vulnerability is that the portal allows users to upload content. This issue has been patched in version 4.1.0. There are no known workarounds for this vulnerability.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-52004
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 13:47 UTC · Revision 1

Source evidence

Remote code execution vulnerabilities in MediaCMS

core-osv · Original source

Published 8 Nov 2024, 22:10 UTC

MediaCMS is an open source video and media CMS, written in Python/Django and React, featuring a REST API. MediaCMS has been prone to vulnerabilities that upon special cases can lead to remote code execution. All versions before v4.1.0 are susceptible, and users are highly recommended to upgrade. The vulnerabilities are related with insufficient input validation while uploading media content. The condition to exploit the vulnerability is that the portal allows users to upload content. This issue has been patched in version 4.1.0. There are no known workarounds for this vulnerability.

osv:CVE-2024-52004
Complete source record
{
  "id": "fe5cac179d7efd48245f8ff173db04bf26d42f3d777545fdbfd596cad480d78c",
  "url": "https://osv.dev/vulnerability/CVE-2024-52004",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Remote code execution vulnerabilities in MediaCMS",
    "summary": "MediaCMS is an open source video and media CMS, written in Python/Django and React, featuring a REST API. MediaCMS has been prone to vulnerabilities that upon special cases can lead to remote code execution. All versions before v4.1.0 are susceptible, and users are highly recommended to upgrade. The vulnerabilities are related with insufficient input validation while uploading media content. The condition to exploit the vulnerability is that the portal allows users to upload content. This issue has been patched in version 4.1.0. There are no known workarounds for this vulnerability.",
    "evidence": "osv:CVE-2024-52004",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2024-52004",
      "aliases": [
        "CVE-2024-52004",
        "GHSA-x3p4-4442-q2c3"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/mediacms-io/mediacms",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "aa8a2d92dcc8f0222dfb93e10511fb7af2d13089"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "4.1.0"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "4.1.0"
                      }
                    ],
                    "source": "DESCRIPTION"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v4.0.1",
            "v4.0.0",
            "v3.5.0",
            "v3.4.0",
            "v3.3.0",
            "v3.2.0",
            "v3.1.0",
            "v3.0.2",
            "v3.0.1",
            "v3.0.0",
            "v2.1.0",
            "2.0.0",
            "v2.0",
            "v1.9",
            "v1.8",
            "v1.7",
            "v1.6",
            "v1.5",
            "v1.4",
            "v1.3",
            "v1.2",
            "v1.1.4",
            "v1.1.3",
            "v1.1.2",
            "v1.1.1",
            "v1.1",
            "v1.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-52004.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:35.931805464Z",
      "provider": "osv",
      "references": [
        "https://github.com/mediacms-io/mediacms/blob/main/docs/admins_docs.md",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/52xxx/CVE-2024-52004.json",
        "https://github.com/mediacms-io/mediacms/security/advisories/GHSA-x3p4-4442-q2c3",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-52004"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-74"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/52xxx/CVE-2024-52004.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-52004",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 503288,
  "published_at": "2024-11-08T22:10:07.361+00:00"
}