libuser — security advisory
libuser before 0.56.13-8 and 0.60 before 0.60-7, as used in the userhelper program in the usermode package, directly modifies /etc/passwd, which allows local users to cause a denial of service (inconsistent file state) by causing an error during the modification. NOTE: this issue can be combined with CVE-2015-3245 to gain privileges.
- Products
- libuser
- Affected versions
- 1:0.56.9.dfsg.1-1.2ubuntu2, 1:0.60~dfsg-1.2, 1:0.64+git20241106~dfsg-2, 1:0.64+git20241106~dfsg-3
- Fixed versions
- 1:0.56.9.dfsg.1-1.2ubuntu2+esm1
- CVEs
- CVE-2015-3246
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 10:26 UTC · Revision 1
Source evidence
libuser before 0.56.13-8 and 0.60 before 0.60-7, as used in the userhelper program in the usermode package, directly modifies /etc/passwd, which allows local users to cause a denial of service (inconsistent file state) by causing an error during the modification. NOTE: this issue can be combined with CVE-2015-3245 to gain privileges.
osv:UBUNTU-CVE-2015-3246
libuser
Fixed versions: 1:0.56.9.dfsg.1-1.2ubuntu2+esm1
libuser
Fixed versions: Not specified
libuser
Fixed versions: Not specified
Complete source record
{
"id": "9bafcf0269bdbae73f2f3b8fd82c8db84aafd64f9f76c1b309d2ffb1a8180a33",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2015-3246",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2015-3246",
"summary": "libuser before 0.56.13-8 and 0.60 before 0.60-7, as used in the userhelper program in the usermode package, directly modifies /etc/passwd, which allows local users to cause a denial of service (inconsistent file state) by causing an error during the modification. NOTE: this issue can be combined with CVE-2015-3245 to gain privileges.",
"evidence": "osv:UBUNTU-CVE-2015-3246",
"products": [
{
"name": {
"value": "libuser",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1:0.56.9.dfsg.1-1.2ubuntu2+esm1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "1:0.56.9.dfsg.1-1.2ubuntu2",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "libuser",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1:0.60~dfsg-1.2",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "libuser",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1:0.64+git20241106~dfsg-2",
"evidence": "/affected/2/versions"
},
{
"value": "1:0.64+git20241106~dfsg-3",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "UBUNTU-CVE-2015-3246",
"aliases": [
"UBUNTU-CVE-2015-3246"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H"
},
{
"type": "Ubuntu",
"score": "high"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1:0.56.9.dfsg.1-1.2ubuntu2+esm1"
}
]
}
],
"package": {
"name": "libuser",
"purl": "pkg:deb/ubuntu/libuser?arch=source&distro=trusty%2Fesm",
"ecosystem": "Ubuntu:Pro:14.04:LTS"
},
"versions": [
"1:0.56.9.dfsg.1-1.2ubuntu2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2015/UBUNTU-CVE-2015-3246.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libuser",
"binary_version": "1:0.56.9.dfsg.1-1.2ubuntu2+esm1"
},
{
"binary_name": "libuser1",
"binary_version": "1:0.56.9.dfsg.1-1.2ubuntu2+esm1"
},
{
"binary_name": "python-libuser",
"binary_version": "1:0.56.9.dfsg.1-1.2ubuntu2+esm1"
}
],
"availability": "Available with Ubuntu Pro (Infra-only): https://ubuntu.com/pro",
"priority_reason": "Listed in CISA Known Exploited Vulnerabilities Catalog"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "libuser",
"purl": "pkg:deb/ubuntu/libuser?arch=source&distro=xenial",
"ecosystem": "Ubuntu:16.04:LTS"
},
"versions": [
"1:0.60~dfsg-1.2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2015/UBUNTU-CVE-2015-3246.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libuser",
"binary_version": "1:0.60~dfsg-1.2"
},
{
"binary_name": "libuser1",
"binary_version": "1:0.60~dfsg-1.2"
},
{
"binary_name": "python-libuser",
"binary_version": "1:0.60~dfsg-1.2"
}
],
"priority_reason": "Listed in CISA Known Exploited Vulnerabilities Catalog"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "libuser",
"purl": "pkg:deb/ubuntu/libuser?arch=source&distro=questing",
"ecosystem": "Ubuntu:25.10"
},
"versions": [
"1:0.64+git20241106~dfsg-2",
"1:0.64+git20241106~dfsg-3"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2015/UBUNTU-CVE-2015-3246.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libuser",
"binary_version": "1:0.64+git20241106~dfsg-3"
},
{
"binary_name": "libuser1",
"binary_version": "1:0.64+git20241106~dfsg-3"
},
{
"binary_name": "python3-libuser",
"binary_version": "1:0.64+git20241106~dfsg-3"
}
],
"priority_reason": "Listed in CISA Known Exploited Vulnerabilities Catalog"
}
}
],
"modified": "2026-10-25T23:30:02.987907271Z",
"provider": "osv",
"upstream": [
"CVE-2015-3246"
],
"references": [
"https://ubuntu.com/security/CVE-2015-3246",
"https://www.cve.org/CVERecord?id=CVE-2015-3246",
"https://www.cisa.gov/known-exploited-vulnerabilities-catalog"
]
},
"related_cves": [
{
"value": "CVE-2015-3246",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 446228,
"published_at": "2015-08-11T14:59:00+00:00"
}