Payload: Sort queries could expose protected field information
### Impact Under certain conditions, sorting readable records could reveal limited information about fields the requester was not permitted to read. You are affected if untrusted users can query a collection, control its sorting, and sort by protected fields. ### Patches Payload now applies field-level access checks to sort fields before executing queries. Users should upgrade to `>= 3.88.0` or `>= 4.0.0-canary.27`. ### Workarounds Upgrading is recommended. Until then, prevent untrusted users from controlling sort parameters or restrict their access to affected collections.
- Products
- payload
- Affected versions
- Not specified
- Fixed versions
- 3.88.0, 4.0.0-canary.27
- CVEs
- CVE-2026-105805
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 27 Oct 2026, 11:46 UTC · Revision 1
Source evidence
Payload: Sort queries could expose protected field information
core-osv · Original sourcePublished 6 Oct 2026, 15:38 UTC
### Impact Under certain conditions, sorting readable records could reveal limited information about fields the requester was not permitted to read. You are affected if untrusted users can query a collection, control its sorting, and sort by protected fields. ### Patches Payload now applies field-level access checks to sort fields before executing queries. Users should upgrade to `>= 3.88.0` or `>= 4.0.0-canary.27`. ### Workarounds Upgrading is recommended. Until then, prevent untrusted users from controlling sort parameters or restrict their access to affected collections.
osv:GHSA-9g87-32v6-3c2r
payload
Fixed versions: 3.88.0
payload
Fixed versions: 4.0.0-canary.27
Complete source record
{
"id": "6f29571a03e7318a2cf53ffd1e32c3307d67110a23001fffa843b7ac8f18333b",
"url": "https://osv.dev/vulnerability/GHSA-9g87-32v6-3c2r",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Payload: Sort queries could expose protected field information",
"summary": "### Impact Under certain conditions, sorting readable records could reveal limited information about fields the requester was not permitted to read. You are affected if untrusted users can query a collection, control its sorting, and sort by protected fields. ### Patches Payload now applies field-level access checks to sort fields before executing queries. Users should upgrade to `>= 3.88.0` or `>= 4.0.0-canary.27`. ### Workarounds Upgrading is recommended. Until then, prevent untrusted users from controlling sort parameters or restrict their access to affected collections.",
"evidence": "osv:GHSA-9g87-32v6-3c2r",
"products": [
{
"name": {
"value": "payload",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.88.0",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "payload",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.0.0-canary.27",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "GHSA-9g87-32v6-3c2r",
"aliases": [
"CVE-2026-105805",
"GHSA-9g87-32v6-3c2r"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.88.0"
}
]
}
],
"package": {
"name": "payload",
"purl": "pkg:npm/payload",
"ecosystem": "npm"
},
"database_specific": {
"source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-9g87-32v6-3c2r/GHSA-9g87-32v6-3c2r.json"
}
},
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "4.0.0-canary.0"
},
{
"fixed": "4.0.0-canary.27"
}
]
}
],
"package": {
"name": "payload",
"purl": "pkg:npm/payload",
"ecosystem": "npm"
},
"database_specific": {
"source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-9g87-32v6-3c2r/GHSA-9g87-32v6-3c2r.json"
}
}
],
"modified": "2026-10-06T15:46:47.481931142Z",
"provider": "osv",
"references": [
"https://github.com/payloadcms/payload/security/advisories/GHSA-9g87-32v6-3c2r",
"https://github.com/payloadcms/payload/commit/a742140ab4fca3160f7f83e9e7d996552ffc3b5a",
"https://github.com/payloadcms/payload",
"https://github.com/payloadcms/payload/releases/tag/v3.88.0"
],
"provider_metadata": {
"cwe_ids": [
"CWE-200",
"CWE-863"
],
"severity": "MODERATE",
"github_reviewed": true,
"nvd_published_at": null,
"github_reviewed_at": "2026-10-06T15:38:32Z"
}
},
"related_cves": [
{
"value": "CVE-2026-105805",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 89263,
"published_at": "2026-10-06T15:38:32+00:00"
}