Critical
Security advisory
Studio 42 elFinder before 2.1.36 has a directory traversal vulnerability in elFinder.class.php with the zipdl() function that can allow a remote attacker to download files accessible by the web server process and delete files owned by the account running the web server process.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2018-9109
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 10:19 UTC · Revision 1
Source evidence
Studio 42 elFinder before 2.1.36 has a directory traversal vulnerability in elFinder.class.php with the zipdl() function that can allow a remote attacker to download files accessible by the web server process and delete files owned by the account running the web server process.
osv:CVE-2018-9109
Complete source record
{
"id": "42afa67273df5d2709d4ad6c00811b041e41a01f0c9d4292497d088f375a271d",
"url": "https://osv.dev/vulnerability/CVE-2018-9109",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2018-9109",
"summary": "Studio 42 elFinder before 2.1.36 has a directory traversal vulnerability in elFinder.class.php with the zipdl() function that can allow a remote attacker to download files accessible by the web server process and delete files owned by the account running the web server process.",
"evidence": "osv:CVE-2018-9109",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2018-9109",
"aliases": [
"CVE-2018-9109",
"GHSA-45x3-mw7q-wf7f"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/studio-42/elfinder",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "4e8d36c4637ebafea5d559bae668d411ba0a1219"
},
{
"fixed": "157f471d7e48f190f74e66eb5bc73360b5352fd3"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:std42:elfinder:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.1.36"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "157f471d7e48f190f74e66eb5bc73360b5352fd3"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "4e8d36c4637ebafea5d559bae668d411ba0a1219"
}
],
"source": "REFERENCES_TAG",
"original_tag": "2.1.36"
}
]
}
}
],
"versions": [
"2.1.35",
"2.1.34",
"2.1.33",
"2.1.32",
"2.1.31",
"2.1.30",
"2.1.29",
"2.1.28",
"2.1.27",
"2.1.26",
"2.1.25",
"2.1.24",
"2.1.23",
"2.1.22",
"2.1.21",
"2.1.20",
"2.1.19",
"2.1.18",
"2.1.17",
"2.1.16",
"2.1.15",
"2.1.14",
"2.1.13",
"2.1.12",
"2.1.11",
"2.1.10",
"2.1.9",
"2.1.8",
"2.1.7",
"2.1.6",
"2.1.5",
"2.1.4",
"2.1.3",
"2.1.2",
"2.1.1",
"2.1.0",
"2.0-beta",
"1.0.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-9109.json"
}
}
],
"modified": "2026-10-20T10:50:09.124404207Z",
"provider": "osv",
"references": [
"https://github.com/Studio-42/elFinder/releases/tag/2.1.36",
"https://github.com/Studio-42/elFinder/wiki/Advisory-about-vulnerability-of-CVE-2018-9109-and-CVE-2018-9110",
"https://github.com/Studio-42/elFinder/commit/157f471d7e48f190f74e66eb5bc73360b5352fd3"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2018-9109",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 381349,
"published_at": "2018-03-28T06:29:00.26+00:00"
}