Server-Side Request Forgery in FlyteConsole
FlyteConsole is the web user interface for the Flyte platform. FlyteConsole prior to version 0.52.0 is vulnerable to server-side request forgery (SSRF) when FlyteConsole is open to the general internet. An attacker can exploit any user of a vulnerable instance to access the internal metadata server or other unauthenticated URLs. Passing of headers to an unauthorized actor may occur. The patch for this issue deletes the entire `cors_proxy`, as this is not required for console anymore. A patch is available in FlyteConsole version 0.52.0. Disable FlyteConsole availability on the internet as a workaround.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-24856
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 03:35 UTC · Revision 1
Source evidence
Server-Side Request Forgery in FlyteConsole
core-osv · Original sourcePublished 17 May 2022, 15:25 UTC
FlyteConsole is the web user interface for the Flyte platform. FlyteConsole prior to version 0.52.0 is vulnerable to server-side request forgery (SSRF) when FlyteConsole is open to the general internet. An attacker can exploit any user of a vulnerable instance to access the internal metadata server or other unauthenticated URLs. Passing of headers to an unauthorized actor may occur. The patch for this issue deletes the entire `cors_proxy`, as this is not required for console anymore. A patch is available in FlyteConsole version 0.52.0. Disable FlyteConsole availability on the internet as a workaround.
osv:CVE-2022-24856
Complete source record
{
"id": "c135c18c6863165cc9966100d81175e97116e78a5777e58f010f6163e9a70ec8",
"url": "https://osv.dev/vulnerability/CVE-2022-24856",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Server-Side Request Forgery in FlyteConsole",
"summary": "FlyteConsole is the web user interface for the Flyte platform. FlyteConsole prior to version 0.52.0 is vulnerable to server-side request forgery (SSRF) when FlyteConsole is open to the general internet. An attacker can exploit any user of a vulnerable instance to access the internal metadata server or other unauthenticated URLs. Passing of headers to an unauthorized actor may occur. The patch for this issue deletes the entire `cors_proxy`, as this is not required for console anymore. A patch is available in FlyteConsole version 0.52.0. Disable FlyteConsole availability on the internet as a workaround.",
"evidence": "osv:CVE-2022-24856",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2022-24856",
"aliases": [
"CVE-2022-24856",
"GHSA-www6-hf2v-v9m9"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/flyteorg/flyteconsole",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "a1f55f45586e8e6682ae1623d6577af25e144003"
},
{
"fixed": "05b88ed2d2ecdb5d8a8404efea25414e57189709"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:flyte:flyte_console:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.52.0"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "05b88ed2d2ecdb5d8a8404efea25414e57189709"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "a1f55f45586e8e6682ae1623d6577af25e144003"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v0.52.0"
}
]
}
}
],
"versions": [
"v0.51.3",
"v0.51.2",
"v0.51.1",
"v0.51.0",
"v0.19.4",
"v0.50.4",
"v0.50.3",
"v0.50.2",
"v0.50.1",
"v0.50.0",
"v0.49.0",
"v0.48.0",
"v0.47.3",
"v0.47.2",
"v0.47.1",
"v0.47.0",
"v0.46.0",
"v0.45.0",
"v0.44.0",
"v0.43.0",
"v0.42.1",
"v0.42.0",
"v0.41.0",
"v0.40.0",
"v0.39.1",
"v0.39.0",
"v0.38.0",
"v0.37.1",
"v0.37.0",
"v0.36.0",
"v0.35.0",
"v0.34.0",
"v0.33.1",
"v0.33.0",
"v0.32.0",
"v0.31.4",
"v0.31.3",
"v0.31.2",
"v0.31.1",
"v0.31.0",
"v0.30.0",
"v0.29.2",
"v0.29.1",
"v0.29.0",
"v0.28.3",
"v0.28.2",
"v0.28.1",
"v0.28.0",
"v0.27.2",
"v0.27.1",
"v0.27.0",
"v0.26.0",
"v0.25.4",
"v0.25.3",
"v0.25.2",
"v0.25.1",
"v0.25.0",
"v0.24.0",
"v0.23.1",
"v0.23.0",
"v0.22.1",
"v0.22.0",
"v0.21.0",
"v0.20.1",
"v0.20.0",
"v0.19.7",
"v0.19.6",
"v0.19.5",
"v0.19.3",
"v0.19.2",
"v0.19.1",
"v0.19.0",
"v0.18.0",
"v0.17.8",
"v0.17.7",
"v0.17.6",
"v0.17.5",
"v0.17.4",
"v0.17.3",
"v0.17.2",
"v0.17.1",
"v0.17.0",
"v0.16.2",
"v0.16.1",
"v0.16.0",
"v0.15.1",
"v0.15.0",
"v0.14.0",
"v0.13.2",
"v0.13.1",
"v0.13.0",
"v0.12.1",
"v0.12.0",
"v0.11.0",
"v0.10.0",
"v0.9.0",
"v0.8.1",
"v0.8.0",
"v0.7.3",
"v0.7.2",
"v0.7.1",
"v0.7.0",
"v0.6.0",
"v0.5.3",
"v0.5.2",
"v0.5.1",
"v0.5.0",
"v0.4.0",
"v0.3.2",
"v0.3.1",
"v0.3.0",
"v0.2.1",
"v0.2.0",
"v0.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-24856.json"
}
}
],
"modified": "2026-10-28T02:30:42.206196206Z",
"provider": "osv",
"references": [
"https://github.com/flyteorg/flyteconsole/releases/tag/v0.52.0",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/24xxx/CVE-2022-24856.json",
"https://github.com/flyteorg/flyteconsole/security/advisories/GHSA-www6-hf2v-v9m9",
"https://nvd.nist.gov/vuln/detail/CVE-2022-24856",
"https://github.com/flyteorg/flyteconsole/commit/05b88ed2d2ecdb5d8a8404efea25414e57189709",
"https://github.com/flyteorg/flyteconsole/pull/389"
],
"provider_metadata": {
"cwe_ids": [
"CWE-918"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/24xxx/CVE-2022-24856.json"
}
},
"related_cves": [
{
"value": "CVE-2022-24856",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 509852,
"published_at": "2022-05-17T15:25:11+00:00"
}