ruby-nokogiri — security advisory
Nokogiri is an open source XML and HTML library for Ruby. Nokogiri prior to version 1.13.6 does not type-check all inputs into the XML and HTML4 SAX parsers, allowing specially crafted untrusted inputs to cause illegal memory access errors (segfault) or reads from unrelated memory. Version 1.13.6 contains a patch for this issue. As a workaround, ensure the untrusted input is a `String` by calling `#to_s` or equivalent.
- Products
- ruby-nokogiri
- Affected versions
- Not specified
- Fixed versions
- 1.13.7+dfsg-1
- CVEs
- CVE-2022-29181
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:38 UTC · Revision 1
Source evidence
Nokogiri is an open source XML and HTML library for Ruby. Nokogiri prior to version 1.13.6 does not type-check all inputs into the XML and HTML4 SAX parsers, allowing specially crafted untrusted inputs to cause illegal memory access errors (segfault) or reads from unrelated memory. Version 1.13.6 contains a patch for this issue. As a workaround, ensure the untrusted input is a `String` by calling `#to_s` or equivalent.
osv:DEBIAN-CVE-2022-29181
ruby-nokogiri
Fixed versions: 1.13.7+dfsg-1
ruby-nokogiri
Fixed versions: 1.13.7+dfsg-1
ruby-nokogiri
Fixed versions: 1.13.7+dfsg-1
Complete source record
{
"id": "a7cc4d9fdd43077335a04ff99a989d22aa89f635f8d67b04539bc4acaeaa3e72",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-29181",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-29181",
"summary": "Nokogiri is an open source XML and HTML library for Ruby. Nokogiri prior to version 1.13.6 does not type-check all inputs into the XML and HTML4 SAX parsers, allowing specially crafted untrusted inputs to cause illegal memory access errors (segfault) or reads from unrelated memory. Version 1.13.6 contains a patch for this issue. As a workaround, ensure the untrusted input is a `String` by calling `#to_s` or equivalent.",
"evidence": "osv:DEBIAN-CVE-2022-29181",
"products": [
{
"name": {
"value": "ruby-nokogiri",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.13.7+dfsg-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ruby-nokogiri",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.13.7+dfsg-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ruby-nokogiri",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.13.7+dfsg-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-29181",
"aliases": [
"DEBIAN-CVE-2022-29181"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.13.7+dfsg-1"
}
]
}
],
"package": {
"name": "ruby-nokogiri",
"purl": "pkg:deb/debian/ruby-nokogiri?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-29181.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.13.7+dfsg-1"
}
]
}
],
"package": {
"name": "ruby-nokogiri",
"purl": "pkg:deb/debian/ruby-nokogiri?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-29181.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.13.7+dfsg-1"
}
]
}
],
"package": {
"name": "ruby-nokogiri",
"purl": "pkg:deb/debian/ruby-nokogiri?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-29181.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
}
],
"modified": "2026-10-15T08:01:12.138107681Z",
"provider": "osv",
"upstream": [
"CVE-2022-29181"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-29181"
]
},
"related_cves": [
{
"value": "CVE-2022-29181",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 322833,
"published_at": "2022-05-20T19:15:08.203+00:00"
}