Command Injection
The package cocoapods-downloader before 1.6.0, from 1.6.2 and before 1.6.3 are vulnerable to Command Injection via git argument injection. When calling the Pod::Downloader.preprocess_options function and using git, both the git and branch parameters are passed to the git ls-remote subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-24440
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 13:57 UTC · Revision 1
Source evidence
The package cocoapods-downloader before 1.6.0, from 1.6.2 and before 1.6.3 are vulnerable to Command Injection via git argument injection. When calling the Pod::Downloader.preprocess_options function and using git, both the git and branch parameters are passed to the git ls-remote subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.
osv:CVE-2022-24440
Complete source record
{
"id": "4f1e0163bcf3481da8f6137698125b1877cf02a0129f8fd5f0a0133c75feaaa2",
"url": "https://osv.dev/vulnerability/CVE-2022-24440",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Command Injection",
"summary": "The package cocoapods-downloader before 1.6.0, from 1.6.2 and before 1.6.3 are vulnerable to Command Injection via git argument injection. When calling the Pod::Downloader.preprocess_options function and using git, both the git and branch parameters are passed to the git ls-remote subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.",
"evidence": "osv:CVE-2022-24440",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2022-24440",
"aliases": [
"CVE-2022-24440",
"GHSA-7627-mp87-jf6q",
"SNYK-RUBY-COCOAPODSDOWNLOADER-2414278"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/cocoapods/cocoapods-downloader",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "e53d02304426c3f7b0f725371c8a5594cecf9be4"
},
{
"introduced": "591167a841c64ca1ae9a8b411c1d1bdffc3bf285"
},
{
"last_affected": "591167a841c64ca1ae9a8b411c1d1bdffc3bf285"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:cocoapods:cocoapods-downloader:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.6.0"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:cocoapods:cocoapods-downloader:1.6.2:*:*:*:*:*:*:*",
"range": [
{
"introduced": "1.6.2"
},
{
"last_affected": "1.6.2"
}
],
"source": "CPE_STRING"
}
]
}
}
],
"versions": [
"1.6.2",
"1.4.0",
"1.2.2",
"1.2.1",
"1.1.3",
"1.1.2",
"1.0.0.rc.1",
"1.0.0.beta.3",
"1.0.0.beta.2",
"1.0.0.beta.1",
"0.9.3",
"0.9.2",
"0.9.1",
"0.9.0",
"0.8.1",
"0.8.0",
"0.7.2",
"v0.7.1",
"v0.7.0",
"0.6.1",
"0.6.0",
"0.5.0",
"0.4.1",
"0.4.0",
"0.3.0",
"0.2.0",
"0.1.2",
"0.1.1",
"0.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-24440.json"
}
}
],
"modified": "2026-10-28T02:30:29.496920760Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/24xxx/CVE-2022-24440.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-24440",
"https://snyk.io/vuln/SNYK-RUBY-COCOAPODSDOWNLOADER-2414278",
"https://github.com/CocoaPods/cocoapods-downloader/pull/124",
"https://github.com/CocoaPods/cocoapods-downloader/pull/128"
],
"provider_metadata": {
"cna_assigner": "snyk",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/24xxx/CVE-2022-24440.json"
}
},
"related_cves": [
{
"value": "CVE-2022-24440",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 496085,
"published_at": "2022-04-01T17:35:13.314+00:00"
}