Apache Hive: Arbitrary command execution via JDBC driver
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Hive. The vulnerability affects the Hive JDBC driver component and it can potentially lead to arbitrary code execution on the machine/endpoint that the JDBC driver (client) is running. The malicious user must have sufficient permissions to specify/edit JDBC URL(s) in an endpoint relying on the Hive JDBC driver and the JDBC client process must run under a privileged user to fully exploit the vulnerability. The attacker can setup a malicious HTTP server and specify a JDBC URL pointing towards this server. When a JDBC connection is attempted, the malicious HTTP server can provide a special response with customized payload that can trigger the execution of certain commands in the JDBC client.This issue affects Apache Hive: from 4.0.0-alpha-1 before 4.0.0. Users are recommended to upgrade to version 4.0.0, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-35701
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 03:27 UTC · Revision 1
Source evidence
Apache Hive: Arbitrary command execution via JDBC driver
core-osv · Original sourcePublished 3 May 2024, 08:11 UTC
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Hive. The vulnerability affects the Hive JDBC driver component and it can potentially lead to arbitrary code execution on the machine/endpoint that the JDBC driver (client) is running. The malicious user must have sufficient permissions to specify/edit JDBC URL(s) in an endpoint relying on the Hive JDBC driver and the JDBC client process must run under a privileged user to fully exploit the vulnerability. The attacker can setup a malicious HTTP server and specify a JDBC URL pointing towards this server. When a JDBC connection is attempted, the malicious HTTP server can provide a special response with customized payload that can trigger the execution of certain commands in the JDBC client.This issue affects Apache Hive: from 4.0.0-alpha-1 before 4.0.0. Users are recommended to upgrade to version 4.0.0, which fixes the issue.
osv:CVE-2023-35701
Complete source record
{
"id": "ead39517a4575f412cd8e6ab3da54fc73ad47f6cf1ffd3be6eefa6d06be5c64c",
"url": "https://osv.dev/vulnerability/CVE-2023-35701",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache Hive: Arbitrary command execution via JDBC driver",
"summary": "Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Hive. The vulnerability affects the Hive JDBC driver component and it can potentially lead to arbitrary code execution on the machine/endpoint that the JDBC driver (client) is running. The malicious user must have sufficient permissions to specify/edit JDBC URL(s) in an endpoint relying on the Hive JDBC driver and the JDBC client process must run under a privileged user to fully exploit the vulnerability. The attacker can setup a malicious HTTP server and specify a JDBC URL pointing towards this server. When a JDBC connection is attempted, the malicious HTTP server can provide a special response with customized payload that can trigger the execution of certain commands in the JDBC client.This issue affects Apache Hive: from 4.0.0-alpha-1 before 4.0.0. Users are recommended to upgrade to version 4.0.0, which fixes the issue.",
"evidence": "osv:CVE-2023-35701",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2023-35701",
"aliases": [
"CVE-2023-35701",
"GHSA-vpw3-3prf-3974"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/hive",
"type": "GIT",
"events": [
{
"introduced": "357d4906f5c806d585fd84db57cf296e12e6049b"
},
{
"fixed": "183f8cb41d3dbed961ffd27999876468ff06690c"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "4.0.0-alpha-1"
},
{
"fixed": "4.0.0"
}
],
"source": "DESCRIPTION"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-35701.json"
}
}
],
"modified": "2026-10-28T02:30:25.589171193Z",
"provider": "osv",
"references": [
"https://repo.maven.apache.org/maven2",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/35xxx/CVE-2023-35701.json",
"https://lists.apache.org/thread/7zcv6l63spl4r66xwz5jv9rtrg2opx81",
"https://nvd.nist.gov/vuln/detail/CVE-2023-35701"
],
"provider_metadata": {
"cwe_ids": [
"CWE-94"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "4.0.0-alpha-1"
},
{
"fixed": "4.0.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/35xxx/CVE-2023-35701.json"
}
},
"related_cves": [
{
"value": "CVE-2023-35701",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 492192,
"published_at": "2024-05-03T08:11:08.215+00:00"
}