High
Security advisory
The Asgaros Forum WordPress plugin before 1.15.15 does not validate or escape the forum_id parameter before using it in a SQL statement when editing a forum, leading to an SQL injection issue
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-25045
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 05:39 UTC · Revision 1
Source evidence
The Asgaros Forum WordPress plugin before 1.15.15 does not validate or escape the forum_id parameter before using it in a SQL statement when editing a forum, leading to an SQL injection issue
osv:CVE-2021-25045
Complete source record
{
"id": "210961e8959d426b3832d67e7f3852feb95c0c697783931d84e65333c818b9ce",
"url": "https://osv.dev/vulnerability/CVE-2021-25045",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-25045",
"summary": "The Asgaros Forum WordPress plugin before 1.15.15 does not validate or escape the forum_id parameter before using it in a SQL statement when editing a forum, leading to an SQL injection issue",
"evidence": "osv:CVE-2021-25045",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2021-25045",
"aliases": [
"CVE-2021-25045"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/asgaros/asgaros-forum",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "93315bb5268325bdfd62447468b08d482d8bce1e"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:asgaros:asgaros_forum:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.15.15"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v1.15.14",
"v1.15.13",
"v1.15.12",
"v1.15.11",
"v1.15.10",
"v1.15.9",
"v1.15.8",
"v1.15.7",
"v1.15.6",
"v1.15.5",
"v1.15.4",
"v1.15.3",
"v1.15.2",
"v1.15.1",
"v1.15.0",
"v1.14.15",
"v1.14.14",
"v1.14.13",
"v1.14.12",
"v1.14.11",
"v1.14.10",
"v1.14.9",
"v1.14.8",
"v1.14.7",
"v1.14.6",
"v1.14.5",
"v1.14.4",
"v1.14.3",
"v1.14.2",
"v1.14.1",
"v1.14.0",
"v1.13.3",
"v1.13.2",
"v1.13.1",
"v1.13.0",
"v1.12.1",
"v1.12.0",
"v1.11.3",
"v1.11.2",
"v1.11.1",
"v1.11.0",
"v1.10.1",
"v1.10.0",
"v1.9.6",
"v1.9.5",
"v1.9.4",
"v1.9.3",
"v1.9.2",
"v1.9.1",
"v1.9.0",
"v1.8.4",
"v1.8.3",
"v1.8.2",
"v1.8.1",
"v1.8.0",
"v1.7.2",
"v1.7.1",
"v1.7.0",
"v1.6.8",
"v1.6.7",
"v1.6.6",
"v1.6.5",
"v1.6.4",
"v1.6.3",
"v1.6.2",
"v1.6.1",
"v1.6.0",
"v1.5.9",
"v1.5.8",
"v1.5.7",
"v1.5.6",
"v1.5.5",
"v1.5.4",
"v1.5.3",
"v1.5.2",
"v1.5.1",
"v1.5.0",
"v1.4.5",
"v1.4.4",
"v1.4.3",
"v1.4.2",
"v1.4.1",
"v1.4.0",
"v1.3.10",
"v1.3.9",
"v1.3.8",
"v1.3.7",
"v1.3.6",
"v1.3.5",
"v1.3.4",
"v1.3.3",
"v1.3.2",
"v1.3.1",
"v1.3.0",
"v1.2.9",
"v1.2.8",
"v1.2.7",
"v1.2.6",
"v1.2.5",
"v1.2.4",
"v1.2.3",
"v1.2.2",
"v1.2.1",
"v1.2.0",
"v1.1.6",
"v1.1.5",
"v1.1.4",
"v1.1.3",
"v1.1.2",
"v1.1.1",
"v1.1.0",
"v1.0.14",
"v1.0.13",
"v1.0.12",
"v1.0.11",
"v1.0.10",
"v1.0.9",
"v1.0.8",
"v1.0.7",
"v1.0.6",
"v1.0.5",
"v1.0.4",
"v1.0.3",
"v1.0.2",
"v1.0.1",
"v1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-25045.json"
}
}
],
"modified": "2026-10-24T10:30:31.955977454Z",
"provider": "osv",
"references": [
"https://plugins.trac.wordpress.org/changeset/2642215",
"https://wpscan.com/vulnerability/c60a3d40-449c-4c84-8d13-68c04267c1d7"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-25045",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 432916,
"published_at": "2022-01-24T08:15:09.543+00:00"
}