Security advisory
In Drupal versions 8.4.x versions before 8.4.5 the Settings Tray module has a vulnerability that allows users to update certain data that they do not have the permissions for. If you have implemented a Settings Tray form in contrib or a custom module, the correct access checks should be added. This release fixes the only two implementations in core, but does not harden against other such bypasses. This vulnerability can be mitigated by disabling the Settings Tray module.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2017-6931
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 04:16 UTC · Revision 1
Source evidence
In Drupal versions 8.4.x versions before 8.4.5 the Settings Tray module has a vulnerability that allows users to update certain data that they do not have the permissions for. If you have implemented a Settings Tray form in contrib or a custom module, the correct access checks should be added. This release fixes the only two implementations in core, but does not harden against other such bypasses. This vulnerability can be mitigated by disabling the Settings Tray module.
osv:CVE-2017-6931
Complete source record
{
"id": "d53fab4aff8743f0cac0b23ab8a8197c6d2682d361973b3a4363095b314aaf90",
"url": "https://osv.dev/vulnerability/CVE-2017-6931",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2017-6931",
"summary": "In Drupal versions 8.4.x versions before 8.4.5 the Settings Tray module has a vulnerability that allows users to update certain data that they do not have the permissions for. If you have implemented a Settings Tray form in contrib or a custom module, the correct access checks should be added. This release fixes the only two implementations in core, but does not harden against other such bypasses. This vulnerability can be mitigated by disabling the Settings Tray module.",
"evidence": "osv:CVE-2017-6931",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2017-6931",
"aliases": [
"CVE-2017-6931",
"GHSA-7ffh-cjvg-fpr4"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/drupal/drupal",
"type": "GIT",
"events": [
{
"introduced": "abfe77673a5a6194ef13600e05f1ca2c5dd59db8"
},
{
"fixed": "3347ff569787d2e659a8c4b5211ea0c76894aa8a"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "8.4.0"
},
{
"fixed": "8.4.5"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"8.4.4",
"8.4.3",
"8.4.1",
"8.4.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-6931.json"
}
}
],
"modified": "2026-10-24T10:30:16.312178425Z",
"provider": "osv",
"references": [
"https://www.drupal.org/sa-core-2018-001"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2017-6931",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 429332,
"published_at": "2018-03-01T23:29:00.497+00:00"
}