OpenCTI vulnerable to Denial of Service through web hook
OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. Prior to version 6.5.2, any user with the capability manage customizations can edit webhook that will execute javascript code. This can be abused to cause a denial of service attack by prototype pollution, making the node js server running the OpenCTI frontend become unavailable. Version 6.5.2 fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-26621
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 13:57 UTC · Revision 1
Source evidence
OpenCTI vulnerable to Denial of Service through web hook
core-osv · Original sourcePublished 19 May 2025, 16:01 UTC
OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. Prior to version 6.5.2, any user with the capability manage customizations can edit webhook that will execute javascript code. This can be abused to cause a denial of service attack by prototype pollution, making the node js server running the OpenCTI frontend become unavailable. Version 6.5.2 fixes the issue.
osv:CVE-2025-26621
Complete source record
{
"id": "5a22a99fe18e0cbb6416181d4e52e80234692af77656e43654a6be50f1a9bbd9",
"url": "https://osv.dev/vulnerability/CVE-2025-26621",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "OpenCTI vulnerable to Denial of Service through web hook",
"summary": "OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. Prior to version 6.5.2, any user with the capability manage customizations can edit webhook that will execute javascript code. This can be abused to cause a denial of service attack by prototype pollution, making the node js server running the OpenCTI frontend become unavailable. Version 6.5.2 fixes the issue.",
"evidence": "osv:CVE-2025-26621",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2025-26621",
"aliases": [
"CVE-2025-26621",
"PYSEC-2025-180"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:L/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/opencti-platform/opencti",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "c7a235883e563734296ada7f1b89ef08638a312f"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "6.5.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:citeum:opencti:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "6.5.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"6.5.1",
"6.4.11",
"6.4.10",
"6.4.9",
"6.4.8",
"6.2.7",
"6.4.7",
"6.4.6",
"6.4.5",
"6.4.4",
"6.4.3",
"6.4.2",
"6.4.1",
"6.4.0",
"6.3.6",
"6.3.5",
"6.3.4",
"6.3.3",
"6.3.1",
"6.3.0",
"6.2.14",
"6.2.13",
"6.2.12",
"6.2.11",
"6.2.10",
"6.2.9",
"6.2.8",
"6.2.6",
"6.2.5",
"6.2.4",
"6.2.3",
"6.2.2",
"6.2.1",
"6.2.0",
"6.1.12",
"6.1.10",
"6.1.9",
"6.1.8",
"6.1.7",
"6.1.6",
"6.1.5",
"6.1.4",
"6.1.3",
"6.1.2",
"6.1.1",
"6.1.0",
"6.0.10",
"6.0.9",
"6.0.8",
"6.0.7",
"6.0.6",
"6.0.5",
"6.0.4",
"6.0.3",
"6.0.2",
"6.0.0",
"5.12.27",
"5.12.26",
"5.12.25",
"5.12.24",
"5.12.23",
"5.12.22",
"5.12.21",
"5.12.20",
"5.12.19",
"5.12.18",
"5.12.17",
"5.12.16",
"5.12.15",
"5.12.14",
"5.12.13",
"5.12.12",
"5.12.11",
"5.12.10",
"5.12.9",
"5.12.8",
"5.12.7",
"5.12.6",
"5.12.5",
"5.12.4",
"5.12.3",
"5.12.2",
"5.12.1",
"5.12.0",
"5.11.13",
"5.11.12",
"5.11.11",
"5.11.10",
"5.11.9",
"5.11.8",
"5.11.7",
"5.11.6",
"5.11.5",
"5.11.4",
"5.11.3",
"5.11.2",
"5.11.1",
"5.11.0",
"5.10.3",
"5.10.2",
"5.10.1",
"5.10.0",
"5.9.6",
"5.9.5",
"5.9.4",
"5.9.3",
"5.9.2",
"5.9.1",
"5.9.0",
"5.8.7",
"5.8.6",
"5.8.5",
"5.8.4",
"5.8.3",
"5.8.2",
"5.8.1",
"5.8.0",
"5.7.6",
"5.7.5",
"5.7.4",
"5.7.3",
"5.7.2",
"5.7.1",
"5.7.0",
"5.6.2",
"5.6.1",
"5.6.0",
"5.5.4",
"5.5.3",
"5.5.2",
"5.5.1",
"5.5.0",
"5.4.1",
"5.4.0",
"5.3.17",
"5.3.16",
"5.3.15",
"5.3.14",
"5.3.13",
"5.3.12",
"5.3.11",
"5.3.10",
"5.3.9",
"5.3.8",
"5.3.7",
"5.3.6",
"5.3.5",
"5.3.4",
"5.3.3",
"5.3.2",
"5.3.1",
"5.3.0",
"5.2.4",
"5.2.3",
"5.2.2",
"5.2.1",
"5.2.0",
"5.1.4",
"5.1.3",
"5.1.2",
"5.1.1",
"5.1.0",
"5.0.3",
"5.0.2",
"5.0.1",
"5.0.0",
"4.5.5",
"4.5.4",
"4.5.3",
"4.5.2",
"4.5.1",
"4.5.0",
"4.4.1",
"4.4.0",
"4.3.5",
"4.3.4",
"4.3.3",
"4.3.2",
"4.3.1",
"4.3.0",
"4.2.4",
"4.2.3",
"4.2.2",
"4.2.1",
"4.2.0",
"4.1.2",
"4.1.1",
"4.1.0",
"4.0.7",
"4.0.6",
"4.0.5",
"4.0.4",
"4.0.3",
"4.0.2",
"4.0.1",
"4.0.0",
"3.3.2",
"3.3.1",
"3.3.0",
"3.2.2",
"3.2.0",
"3.0.3",
"3.0.2",
"3.0.1",
"3.0.0",
"2.1.4",
"2.1.3",
"2.1.2",
"2.1.1",
"2.1.0",
"2.0.2",
"2.0.1",
"1.1.2",
"1.1.0",
"1.0.2",
"1.0.1",
"1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-26621.json"
}
}
],
"modified": "2026-10-28T02:30:29.396743344Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/26xxx/CVE-2025-26621.json",
"https://github.com/OpenCTI-Platform/opencti/security/advisories/GHSA-gq63-jm3h-374p",
"https://github.com/OpenCTI-Platform/opencti/security/advisories/GHSA-mf88-g2wq-p7qm",
"https://nvd.nist.gov/vuln/detail/CVE-2025-26621"
],
"provider_metadata": {
"cwe_ids": [
"CWE-94"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/26xxx/CVE-2025-26621.json"
}
},
"related_cves": [
{
"value": "CVE-2025-26621",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 496164,
"published_at": "2025-05-19T16:01:50.419+00:00"
}