UnratedFix available
phppgadmin — security advisory
John Lim ADOdb Library for PHP before 4.23 allows remote attackers to obtain sensitive information via direct requests to certain scripts that result in an undefined value of ADODB_DIR, which reveals the installation path in an error message.
- Products
- phppgadmin
- Affected versions
- Not specified
- Fixed versions
- 4.0.1-2
- CVEs
- CVE-2004-2664
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 14:24 UTC · Revision 1
Source evidence
John Lim ADOdb Library for PHP before 4.23 allows remote attackers to obtain sensitive information via direct requests to certain scripts that result in an undefined value of ADODB_DIR, which reveals the installation path in an error message.
osv:DEBIAN-CVE-2004-2664
phppgadmin
Fixed versions: 4.0.1-2
phppgadmin
Fixed versions: 4.0.1-2
Complete source record
{
"id": "4f23424de85eed5e2a11ded7fd11e264d28f2656b4f295573631ac4d6863497f",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2004-2664",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2004-2664",
"summary": "John Lim ADOdb Library for PHP before 4.23 allows remote attackers to obtain sensitive information via direct requests to certain scripts that result in an undefined value of ADODB_DIR, which reveals the installation path in an error message.",
"evidence": "osv:DEBIAN-CVE-2004-2664",
"products": [
{
"name": {
"value": "phppgadmin",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.0.1-2",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "phppgadmin",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.0.1-2",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2004-2664",
"aliases": [
"DEBIAN-CVE-2004-2664"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.0.1-2"
}
]
}
],
"package": {
"name": "phppgadmin",
"purl": "pkg:deb/debian/phppgadmin?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2004-2664.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.0.1-2"
}
]
}
],
"package": {
"name": "phppgadmin",
"purl": "pkg:deb/debian/phppgadmin?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2004-2664.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
}
],
"modified": "2026-10-21T15:47:28.713125591Z",
"provider": "osv",
"upstream": [
"CVE-2004-2664"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2004-2664"
]
},
"related_cves": [
{
"value": "CVE-2004-2664",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 393911,
"published_at": "2004-12-31T05:00:00+00:00"
}