Skip to content
Heist/ feed
Back to feed
Critical

WPZOOM Addons for Elementor (Templates, Widgets) <= 1.1.37 - Unauthenticated Local File Inclusion

Type: advisorySources: OSV

The WPZOOM Addons for Elementor (Templates, Widgets) plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 1.1.37 via the 'grid_style' parameter. This makes it possible for unauthenticated attackers to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-5147
Confirmed fixed CVEs
Not specified
Updated in this feed
8 Nov 2026, 01:34 UTC · Revision 1

Source evidence

WPZOOM Addons for Elementor (Templates, Widgets) <= 1.1.37 - Unauthenticated Local File Inclusion

core-osv · Original source

Published 22 May 2024, 07:37 UTC

The WPZOOM Addons for Elementor (Templates, Widgets) plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 1.1.37 via the 'grid_style' parameter. This makes it possible for unauthenticated attackers to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.

osv:CVE-2024-5147
Complete source record
{
  "id": "96dca20457e4b11ca1687cb8e4d5b0905719b821c7e7a54bbc64dbed264ea684",
  "url": "https://osv.dev/vulnerability/CVE-2024-5147",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "WPZOOM Addons for Elementor (Templates, Widgets) <= 1.1.37 - Unauthenticated Local File Inclusion",
    "summary": "The WPZOOM Addons for Elementor (Templates, Widgets) plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 1.1.37 via the 'grid_style' parameter. This makes it possible for unauthenticated attackers to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.",
    "evidence": "osv:CVE-2024-5147",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2024-5147",
      "aliases": [
        "CVE-2024-5147"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/wpzoom/wpzoom-elementor-addons",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "6707f68f4b65684e35c26319f92d60abfee945ac"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:wpzoom:wpzoom_elementor_addons:*:*:*:*:*:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.1.38"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.1.37",
            "1.1.36",
            "1.1.35",
            "1.1.34",
            "1.1.33",
            "1.1.32",
            "1.1.31",
            "1.1.30",
            "1.1.29",
            "1.1.28",
            "1.1.27",
            "1.1.26",
            "1.1.25",
            "1.1.24",
            "1.1.23",
            "1.1.22",
            "1.1.21",
            "1.1.20",
            "1.1.19",
            "1.1.18",
            "1.1.17",
            "1.1.16",
            "1.1.15"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-5147.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:52.444203508Z",
      "provider": "osv",
      "references": [
        "https://plugins.trac.wordpress.org/browser/wpzoom-elementor-addons/trunk/includes/wpzoom-elementor-ajax-posts-grid.php#L105",
        "https://plugins.trac.wordpress.org/browser/wpzoom-elementor-addons/trunk/includes/wpzoom-elementor-ajax-posts-grid.php#L112",
        "https://plugins.trac.wordpress.org/changeset/3090236#file6",
        "https://www.wordfence.com/threat-intel/vulnerabilities/id/f006bb33-d017-445b-9c02-bd848c199671?source=cve",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/5xxx/CVE-2024-5147.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-5147"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-22"
        ],
        "cna_assigner": "Wordfence",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "last_affected": "1.1.37"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/5xxx/CVE-2024-5147.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-5147",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 521388,
  "published_at": "2024-05-22T07:37:25.726+00:00"
}