Skip to content
Heist/ feed
Back to feed
UnratedFix available

putty — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2004-1440

Multiple heap-based buffer overflows in the modpow function in PuTTY before 0.55 allow (1) remote attackers to execute arbitrary code via an SSH2 packet with a base argument that is larger than the mod argument, which causes the modpow function to write memory before the beginning of its buffer, and (2) remote malicious servers to cause a denial of service (client crash) and possibly execute arbitrary code via a large bignum during authentication.

Products
putty
Affected versions
Not specified
Fixed versions
0.56-1
CVEs
CVE-2004-1440
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 14:25 UTC · Revision 1

Source evidence

DEBIAN-CVE-2004-1440

core-osv · Original source

Published 31 Dec 2004, 05:00 UTC

Multiple heap-based buffer overflows in the modpow function in PuTTY before 0.55 allow (1) remote attackers to execute arbitrary code via an SSH2 packet with a base argument that is larger than the mod argument, which causes the modpow function to write memory before the beginning of its buffer, and (2) remote malicious servers to cause a denial of service (client crash) and possibly execute arbitrary code via a large bignum during authentication.

osv:DEBIAN-CVE-2004-1440

putty

Fixed versions: 0.56-1

putty

Fixed versions: 0.56-1

putty

Fixed versions: 0.56-1

Complete source record
{
  "id": "fa26bf68d5d33f1772e4d0f76a67f7adc311d2962eff679f1710cc9b7abaf994",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2004-1440",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2004-1440",
    "summary": "Multiple heap-based buffer overflows in the modpow function in PuTTY before 0.55 allow (1) remote attackers to execute arbitrary code via an SSH2 packet with a base argument that is larger than the mod argument, which causes the modpow function to write memory before the beginning of its buffer, and (2) remote malicious servers to cause a denial of service (client crash) and possibly execute arbitrary code via a large bignum during authentication.",
    "evidence": "osv:DEBIAN-CVE-2004-1440",
    "products": [
      {
        "name": {
          "value": "putty",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.56-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "putty",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.56-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "putty",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.56-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "unknown",
    "structured": {
      "id": "DEBIAN-CVE-2004-1440",
      "aliases": [
        "DEBIAN-CVE-2004-1440"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.56-1"
                }
              ]
            }
          ],
          "package": {
            "name": "putty",
            "purl": "pkg:deb/debian/putty?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2004-1440.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.56-1"
                }
              ]
            }
          ],
          "package": {
            "name": "putty",
            "purl": "pkg:deb/debian/putty?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2004-1440.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.56-1"
                }
              ]
            }
          ],
          "package": {
            "name": "putty",
            "purl": "pkg:deb/debian/putty?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2004-1440.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-21T15:47:34.944224995Z",
      "provider": "osv",
      "upstream": [
        "CVE-2004-1440"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2004-1440"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2004-1440",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-osv",
  "document_id": 394014,
  "published_at": "2004-12-31T05:00:00+00:00"
}