Skip to content
Heist/ feed
Back to feed
Unrated

Welcart e-Commerce < 2.12.6 - Author+ Arbitrary Product SKU Update and Disclosure via item_sku_ajax

Type: advisorySources: Official CVE List

The Welcart e-Commerce WordPress plugin before 2.12.6 does not properly verify authorization against the targeted product before processing SKU changes, because its capability check is not tied to the product being edited, allowing any authenticated user with Author-level access or higher to read, modify, create, delete and re-order the SKU data (including prices, confidential cost prices and stock levels) of any product, including those belonging to other users.

Products
Welcart e-Commerce
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-111032
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 21:56 UTC · Revision 1

Source evidence

Welcart e-Commerce < 2.12.6 - Author+ Arbitrary Product SKU Update and Disclosure via item_sku_ajax

core-cve · Original source

Published 28 Oct 2026, 06:00 UTC

The Welcart e-Commerce WordPress plugin before 2.12.6 does not properly verify authorization against the targeted product before processing SKU changes, because its capability check is not tied to the product being edited, allowing any authenticated user with Author-level access or higher to read, modify, create, delete and re-order the SKU data (including prices, confidential cost prices and stock levels) of any product, including those belonging to other users.

cve:CVE-2026-111032

Welcart e-Commerce

Fixed versions: Not specified

Complete source record
{
  "id": "03aae864d3b6d60c44d51d49a76f327ddf585d557ccf5ec778a35db91d2283bd",
  "url": "https://www.cve.org/CVERecord?id=CVE-2026-111032",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Welcart e-Commerce < 2.12.6 - Author+ Arbitrary Product SKU Update and Disclosure via item_sku_ajax",
    "summary": "The Welcart e-Commerce WordPress plugin before 2.12.6 does not properly verify authorization against the targeted product before processing SKU changes, because its capability check is not tied to the product being edited, allowing any authenticated user with Author-level access or higher to read, modify, create, delete and re-order the SKU data (including prices, confidential cost prices and stock levels) of any product, including those belonging to other users.",
    "evidence": "cve:CVE-2026-111032",
    "products": [
      {
        "name": {
          "value": "Welcart e-Commerce",
          "evidence": "/containers/cna/affected/0/product"
        },
        "prerequisites": [],
        "fixed_versions": [],
        "affected_versions": []
      }
    ],
    "severity": "unknown",
    "structured": {
      "id": "CVE-2026-111032",
      "aliases": [
        "CVE-2026-111032"
      ],
      "metrics": [],
      "affected": [
        {
          "vendor": "Unknown",
          "product": "Welcart e-Commerce",
          "versions": [
            {
              "status": "affected",
              "version": "0",
              "lessThan": "2.12.6",
              "versionType": "semver"
            }
          ],
          "defaultStatus": "unaffected"
        }
      ],
      "modified": "2026-10-28T17:58:06.341Z",
      "provider": "cve",
      "references": [
        "https://wpscan.com/vulnerability/73a9a609-b647-4872-96d3-b066df0870ee/"
      ],
      "provider_metadata": {
        "adp": [
          {
            "title": "CISA ADP Vulnrichment",
            "metrics": [
              {
                "cvssV3_1": {
                  "scope": "UNCHANGED",
                  "version": "3.1",
                  "baseScore": 3.8,
                  "attackVector": "NETWORK",
                  "baseSeverity": "LOW",
                  "vectorString": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N",
                  "integrityImpact": "LOW",
                  "userInteraction": "NONE",
                  "attackComplexity": "LOW",
                  "availabilityImpact": "NONE",
                  "privilegesRequired": "HIGH",
                  "confidentialityImpact": "LOW"
                }
              },
              {
                "other": {
                  "type": "ssvc",
                  "content": {
                    "id": "CVE-2026-111032",
                    "role": "CISA Coordinator",
                    "options": [
                      {
                        "Exploitation": "none"
                      },
                      {
                        "Automatable": "no"
                      },
                      {
                        "Technical Impact": "partial"
                      }
                    ],
                    "version": "2.0.3",
                    "timestamp": "2026-10-28T17:44:04.743495Z"
                  }
                }
              }
            ],
            "problemTypes": [
              {
                "descriptions": [
                  {
                    "lang": "en",
                    "type": "CWE",
                    "cweId": "CWE-863",
                    "description": "CWE-863 Incorrect Authorization"
                  }
                ]
              }
            ],
            "providerMetadata": {
              "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
              "shortName": "CISA-ADP",
              "dateUpdated": "2026-10-28T17:58:06.341Z"
            }
          }
        ],
        "cna": {
          "orgId": "1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81",
          "shortName": "WPScan",
          "dateUpdated": "2026-10-28T06:00:24.660Z"
        }
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-111032",
        "evidence": "/cveMetadata/cveId"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-cve",
  "document_id": 470532,
  "published_at": "2026-10-28T06:00:24.66+00:00"
}