Skip to content
Heist/ feed
Back to feed
High

Sentry's superuser cleartext password leaked in logs

Type: advisorySources: OSV

Sentry is an error tracking and performance monitoring platform. Prior to 24.4.1, when authenticating as a superuser to Sentry with a username and password, the password is leaked as cleartext in logs under the _event_: `auth-index.validate_superuser`. An attacker with access to the log data could use these leaked credentials to login to the Sentry system as superuser. Self-hosted users on affected versions should upgrade to 24.4.1 or later. Users can configure the logging level to exclude logs of the `INFO` level and only generate logs for levels at `WARNING` or more.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-32474
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 17:48 UTC · Revision 1

Source evidence

Sentry's superuser cleartext password leaked in logs

core-osv · Original source

Published 18 Apr 2024, 19:50 UTC

Sentry is an error tracking and performance monitoring platform. Prior to 24.4.1, when authenticating as a superuser to Sentry with a username and password, the password is leaked as cleartext in logs under the _event_: `auth-index.validate_superuser`. An attacker with access to the log data could use these leaked credentials to login to the Sentry system as superuser. Self-hosted users on affected versions should upgrade to 24.4.1 or later. Users can configure the logging level to exclude logs of the `INFO` level and only generate logs for levels at `WARNING` or more.

osv:CVE-2024-32474
Complete source record
{
  "id": "f6d03b8be308a4dc11d566ba19b133f5d5b3d74a1dff2586925b93cb7c1c24cf",
  "url": "https://osv.dev/vulnerability/CVE-2024-32474",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Sentry's superuser cleartext password leaked in logs",
    "summary": "Sentry is an error tracking and performance monitoring platform. Prior to 24.4.1, when authenticating as a superuser to Sentry with a username and password, the password is leaked as cleartext in logs under the _event_: `auth-index.validate_superuser`. An attacker with access to the log data could use these leaked credentials to login to the Sentry system as superuser. Self-hosted users on affected versions should upgrade to 24.4.1 or later. Users can configure the logging level to exclude logs of the `INFO` level and only generate logs for levels at `WARNING` or more.",
    "evidence": "osv:CVE-2024-32474",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2024-32474",
      "aliases": [
        "CVE-2024-32474",
        "GHSA-6cjm-4pxw-7xp9",
        "PYSEC-2026-1911"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/getsentry/sentry",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0a10a6673af4dddf789eed5da132a20f2ff2f4f3"
                },
                {
                  "fixed": "db71b8db26d741bb686c6a4876c0bc5f73af80c9"
                },
                {
                  "fixed": "d5b34568d9f1c41362ccb62141532a0a2169512f"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:sentry:sentry:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "24.3.0"
                      },
                      {
                        "fixed": "24.4.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "d5b34568d9f1c41362ccb62141532a0a2169512f"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-32474.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:31.008234925Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/32xxx/CVE-2024-32474.json",
        "https://github.com/getsentry/sentry/security/advisories/GHSA-6cjm-4pxw-7xp9",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-32474",
        "https://github.com/getsentry/sentry/commit/d5b34568d9f1c41362ccb62141532a0a2169512f",
        "https://github.com/getsentry/sentry/pull/66393",
        "https://github.com/getsentry/sentry/pull/69148"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-117",
          "CWE-312"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/32xxx/CVE-2024-32474.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-32474",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 498009,
  "published_at": "2024-04-18T19:50:44.541+00:00"
}