Medium
Apache Ambari: Various XSS problems
Type: advisorySources: OSV
Lack of proper input validation and constraint enforcement in Apache Ambari prior to 2.7.8 Impact : As it will be stored XSS, Could be exploited to perform unauthorized actions, varying from data access to session hijacking and delivering malicious payloads. Users are recommended to upgrade to version 2.7.8 which fixes this issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-50378
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 01:54 UTC · Revision 1
Source evidence
Lack of proper input validation and constraint enforcement in Apache Ambari prior to 2.7.8 Impact : As it will be stored XSS, Could be exploited to perform unauthorized actions, varying from data access to session hijacking and delivering malicious payloads. Users are recommended to upgrade to version 2.7.8 which fixes this issue.
osv:CVE-2023-50378
Complete source record
{
"id": "567bf0de679d80f65e4876ec983e1beb5851ac54e3749a6116c59fe11d187670",
"url": "https://osv.dev/vulnerability/CVE-2023-50378",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache Ambari: Various XSS problems",
"summary": "Lack of proper input validation and constraint enforcement in Apache Ambari prior to 2.7.8 Impact : As it will be stored XSS, Could be exploited to perform unauthorized actions, varying from data access to session hijacking and delivering malicious payloads. Users are recommended to upgrade to version 2.7.8 which fixes this issue.",
"evidence": "osv:CVE-2023-50378",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2023-50378",
"aliases": [
"CVE-2023-50378",
"GHSA-9q6v-rxmw-g3gh"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/ambari",
"type": "GIT",
"events": [
{
"introduced": "da4e607a48033ab1f359b3ace302fcf29d823e38"
},
{
"fixed": "da8f1b9b5a799bfa8e2d8aa9ab31d6d5a1cc31a0"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:ambari:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.7.0"
},
{
"fixed": "2.7.8"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"release-2.7.6-rc1",
"release-2.7.6",
"release-2.7.6-rc0",
"release-2.7.5-rc0",
"release-2.7.5",
"release-2.7.4-rc0",
"release-2.7.4",
"release-2.7.3-rc2",
"release-2.7.3",
"release-2.7.3-rc1",
"release-2.7.3-rc0",
"release-2.7.1-rc0",
"release-2.7.1",
"release-2.7.0-rc0",
"release-2.7.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-50378.json"
}
}
],
"modified": "2026-10-28T02:30:48.752007823Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/50xxx/CVE-2023-50378.json",
"https://lists.apache.org/thread/6hn0thq743vz9gh283s2d87wz8tqh37c",
"https://nvd.nist.gov/vuln/detail/CVE-2023-50378"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "2.7.0"
},
{
"last_affected": "2.7.7"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/50xxx/CVE-2023-50378.json"
}
},
"related_cves": [
{
"value": "CVE-2023-50378",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 517145,
"published_at": "2024-03-01T14:38:29.732+00:00"
}