Critical
Security advisory
PHP 7.x through 7.1.5 allows remote attackers to cause a denial of service (buffer overflow and application crash) or possibly have unspecified other impact via a long string because of an Integer overflow in mysqli_real_escape_string.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2017-9120
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 04:39 UTC · Revision 1
Source evidence
PHP 7.x through 7.1.5 allows remote attackers to cause a denial of service (buffer overflow and application crash) or possibly have unspecified other impact via a long string because of an Integer overflow in mysqli_real_escape_string.
osv:CVE-2017-9120
Complete source record
{
"id": "2fc3e370bca1f4c16ef9bf976fae0564067366b878c41ad6bb4e23dc929ce0e7",
"url": "https://osv.dev/vulnerability/CVE-2017-9120",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2017-9120",
"summary": "PHP 7.x through 7.1.5 allows remote attackers to cause a denial of service (buffer overflow and application crash) or possibly have unspecified other impact via a long string because of an Integer overflow in mysqli_real_escape_string.",
"evidence": "osv:CVE-2017-9120",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2017-9120",
"aliases": [
"CVE-2017-9120"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/php/php-src",
"type": "GIT",
"events": [
{
"introduced": "60fffd296abce5fc071f3c173c25a2696cf683c6"
},
{
"last_affected": "5d08c710749096291e294afd641e4429760c6c6e"
},
{
"introduced": "3c7824e16ec4c3cee417262445d2c2b66531c10f"
},
{
"fixed": "afe3c74a79137e77750fc683ecb6a526e6845bb1"
},
{
"introduced": "5dc92c2117cafc61daaaaa240fd46c3ac33872a4"
},
{
"fixed": "55778e127668ded5a75a499b6a818987a3b00864"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:php:php:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "7.0.0"
},
{
"last_affected": "7.1.5"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:php:php:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "7.4.0"
},
{
"fixed": "7.4.23"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:php:php:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "8.0.0"
},
{
"fixed": "8.0.10"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-9120.json"
}
}
],
"modified": "2026-10-24T10:30:21.486829022Z",
"provider": "osv",
"references": [
"https://access.redhat.com/errata/RHSA-2019:2519",
"https://security.netapp.com/advisory/ntap-20181107-0003/",
"https://bugs.php.net/bug.php?id=74544"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2017-9120",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 430491,
"published_at": "2018-08-02T15:29:00.277+00:00"
}