rust-openssl: Out-of-bounds read in PEM password callback when user callback returns an oversized length
rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.9.0 to before 0.10.78, the *_from_pem_callback APIs did not validate the length returned by the user's callback. A password callback that returns a value larger than the buffer it was given can cause some versions of OpenSSL to over-read this buffer. OpenSSL 3.x is not affected by this. This vulnerability is fixed in 0.10.78.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-41677
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 07:12 UTC · Revision 1
Source evidence
rust-openssl: Out-of-bounds read in PEM password callback when user callback returns an oversized length
core-osv · Original sourcePublished 24 Apr 2026, 17:17 UTC
rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.9.0 to before 0.10.78, the *_from_pem_callback APIs did not validate the length returned by the user's callback. A password callback that returns a value larger than the buffer it was given can cause some versions of OpenSSL to over-read this buffer. OpenSSL 3.x is not affected by this. This vulnerability is fixed in 0.10.78.
osv:CVE-2026-41677
Complete source record
{
"id": "d3d680fe4ce1d3eec2b4e40b6b37fa1918fc6a6420cb9fcad16c01e489520a16",
"url": "https://osv.dev/vulnerability/CVE-2026-41677",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "rust-openssl: Out-of-bounds read in PEM password callback when user callback returns an oversized length",
"summary": "rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.9.0 to before 0.10.78, the *_from_pem_callback APIs did not validate the length returned by the user's callback. A password callback that returns a value larger than the buffer it was given can cause some versions of OpenSSL to over-read this buffer. OpenSSL 3.x is not affected by this. This vulnerability is fixed in 0.10.78.",
"evidence": "osv:CVE-2026-41677",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2026-41677",
"aliases": [
"CVE-2026-41677",
"GHSA-xmgf-hq76-4vx2"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N/E:U"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/rust-openssl/rust-openssl",
"type": "GIT",
"events": [
{
"introduced": "a0b56c437803a08413755928040a0970a93a7b83"
},
{
"fixed": "a6debf535674c9a073f455158743e6ba094cf1b4"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0.9.0"
},
{
"fixed": "0.10.78"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:rust-openssl_project:rust-openssl:*:*:*:*:*:rust:*:*",
"range": [
{
"introduced": "0.9.0"
},
{
"fixed": "0.10.78"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-41677.json"
}
}
],
"modified": "2026-10-28T02:30:26.714236196Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/41xxx/CVE-2026-41677.json",
"https://github.com/rust-openssl/rust-openssl/security/advisories/GHSA-xmgf-hq76-4vx2",
"https://nvd.nist.gov/vuln/detail/CVE-2026-41677"
],
"provider_metadata": {
"cwe_ids": [
"CWE-125",
"CWE-1284"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/41xxx/CVE-2026-41677.json"
}
},
"related_cves": [
{
"value": "CVE-2026-41677",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 493306,
"published_at": "2026-04-24T17:17:17.849+00:00"
}