Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2021-20619

Cross-site scripting vulnerability in GROWI (v4.2 Series) versions prior to v4.2.3 allows remote attackers to inject an arbitrary script via unspecified vectors.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2021-20619
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 11:31 UTC · Revision 1

Source evidence

CVE-2021-20619

core-osv · Original source

Published 19 Jan 2021, 05:15 UTC

Cross-site scripting vulnerability in GROWI (v4.2 Series) versions prior to v4.2.3 allows remote attackers to inject an arbitrary script via unspecified vectors.

osv:CVE-2021-20619
Complete source record
{
  "id": "a1b23b53ea1580b34b3770a0abcfcc4377d2fd7eb9189814feeb1599eac081f9",
  "url": "https://osv.dev/vulnerability/CVE-2021-20619",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2021-20619",
    "summary": "Cross-site scripting vulnerability in GROWI (v4.2 Series) versions prior to v4.2.3 allows remote attackers to inject an arbitrary script via unspecified vectors.",
    "evidence": "osv:CVE-2021-20619",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2021-20619",
      "aliases": [
        "CVE-2021-20619"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/growilabs/growi",
              "type": "GIT",
              "events": [
                {
                  "introduced": "ab5ef887884fb8f16d4f68c93854b9eca7374d96"
                },
                {
                  "fixed": "57a8c62f9f9da8a9fc474ae5e752e9e313c4b8ca"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:weseek:growi:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "4.2.0"
                      },
                      {
                        "fixed": "4.2.3"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-20619.json"
          }
        }
      ],
      "modified": "2026-10-20T10:54:27.394445995Z",
      "provider": "osv",
      "references": [
        "https://jvn.jp/en/jp/JVN57544707/index.html",
        "https://weseek.co.jp/security/2021/01/18/vulnerability/growi-prevent-xss4/",
        "https://github.com/weseek/growi"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2021-20619",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 385373,
  "published_at": "2021-01-19T05:15:13.933+00:00"
}