Skip to content
Heist/ feed
Back to feed
Medium

WordPress Cooked Plugin Persistent Cross-Site Scripting via Shortcode

Type: advisorySources: OSV

Cooked is a recipe plugin for WordPress. The Cooked plugin for WordPress is vulnerable to Persistent Cross-Site Scripting (XSS) via the ‘[cooked-timer]’ shortcode in versions up to, and including, 1.8.0 due to insufficient input sanitization and output escaping. This vulnerability allows authenticated attackers with subscriber-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses a compromised page. This issue has been addressed in release version 1.8.1. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-41816
Confirmed fixed CVEs
Not specified
Updated in this feed
8 Nov 2026, 03:08 UTC · Revision 1

Source evidence

WordPress Cooked Plugin Persistent Cross-Site Scripting via Shortcode

core-osv · Original source

Published 5 Aug 2024, 20:12 UTC

Cooked is a recipe plugin for WordPress. The Cooked plugin for WordPress is vulnerable to Persistent Cross-Site Scripting (XSS) via the ‘[cooked-timer]’ shortcode in versions up to, and including, 1.8.0 due to insufficient input sanitization and output escaping. This vulnerability allows authenticated attackers with subscriber-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses a compromised page. This issue has been addressed in release version 1.8.1. All users are advised to upgrade. There are no known workarounds for this vulnerability.

osv:CVE-2024-41816
Complete source record
{
  "id": "6fd81535d7ec0022635ae0d49608eab8e517505c75ca2136d2f820edf8353117",
  "url": "https://osv.dev/vulnerability/CVE-2024-41816",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "WordPress Cooked Plugin Persistent Cross-Site Scripting via Shortcode",
    "summary": "Cooked is a recipe plugin for WordPress. The Cooked plugin for WordPress is vulnerable to Persistent Cross-Site Scripting (XSS) via the ‘[cooked-timer]’ shortcode in versions up to, and including, 1.8.0 due to insufficient input sanitization and output escaping. This vulnerability allows authenticated attackers with subscriber-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses a compromised page. This issue has been addressed in release version 1.8.1. All users are advised to upgrade. There are no known workarounds for this vulnerability.",
    "evidence": "osv:CVE-2024-41816",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2024-41816",
      "aliases": [
        "CVE-2024-41816",
        "GHSA-3gw3-2qjq-xqjj"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/xjsv/cooked",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "fb2c0657286eed7b0c3a2f12859827c8afcfab38"
                },
                {
                  "fixed": "ac7455bdccc99fb2f5b3c7611312947c1623c3ec"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:boxystudio:cooked:*:*:*:*:pro:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.8.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "ac7455bdccc99fb2f5b3c7611312947c1623c3ec"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v1.8.0",
            "v1.7.15.4",
            "v1.7.15.3",
            "v1.7.15.2",
            "v1.7.14"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-41816.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:53.199192175Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/41xxx/CVE-2024-41816.json",
        "https://github.com/XjSv/Cooked/security/advisories/GHSA-3gw3-2qjq-xqjj",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-41816",
        "https://github.com/XjSv/Cooked/commit/ac7455bdccc99fb2f5b3c7611312947c1623c3ec"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/41xxx/CVE-2024-41816.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-41816",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 522074,
  "published_at": "2024-08-05T20:12:41.428+00:00"
}