Dyad Vulnerable to Remote Code Execution via Top-level Navigation in Preview Window
Dyad is a local AI app builder. A critical security vulnerability has been discovered that affected Dyad v0.19.0 and earlier versions that allows attackers to execute arbitrary code on users' systems. The vulnerability affects the application's preview window functionality and can bypass Docker container protections. An attacker can craft web content that automatically executes when the preview loads. The malicious content can break out of the application's security boundaries and gain control of the system. This has been fixed in Dyad v0.20.0 and later.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-58766
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 17:56 UTC · Revision 1
Source evidence
Dyad Vulnerable to Remote Code Execution via Top-level Navigation in Preview Window
core-osv · Original sourcePublished 17 Sept 2025, 17:36 UTC
Dyad is a local AI app builder. A critical security vulnerability has been discovered that affected Dyad v0.19.0 and earlier versions that allows attackers to execute arbitrary code on users' systems. The vulnerability affects the application's preview window functionality and can bypass Docker container protections. An attacker can craft web content that automatically executes when the preview loads. The malicious content can break out of the application's security boundaries and gain control of the system. This has been fixed in Dyad v0.20.0 and later.
osv:CVE-2025-58766
Complete source record
{
"id": "8a338006feac8af89a3ed84de7b46ad714b418fd7065b0b0c593f2bc9926cbdd",
"url": "https://osv.dev/vulnerability/CVE-2025-58766",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Dyad Vulnerable to Remote Code Execution via Top-level Navigation in Preview Window",
"summary": "Dyad is a local AI app builder. A critical security vulnerability has been discovered that affected Dyad v0.19.0 and earlier versions that allows attackers to execute arbitrary code on users' systems. The vulnerability affects the application's preview window functionality and can bypass Docker container protections. An attacker can craft web content that automatically executes when the preview loads. The malicious content can break out of the application's security boundaries and gain control of the system. This has been fixed in Dyad v0.20.0 and later.",
"evidence": "osv:CVE-2025-58766",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2025-58766",
"aliases": [
"CVE-2025-58766",
"GHSA-7fxm-c5xx-7vpq"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/dyad-sh/dyad",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "e962964afed9d8bcec075521098ca5a539267595"
},
{
"fixed": "1c0255ab126d3b38ae9e78b17cdab9a07e5f0185"
},
{
"fixed": "ebcf89ee6cead83a33add5ef1e19c8d4f9b4ce9b"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "0.20.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "1c0255ab126d3b38ae9e78b17cdab9a07e5f0185"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "ebcf89ee6cead83a33add5ef1e19c8d4f9b4ce9b"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v0.19.0",
"v0.19.0-beta.1",
"v0.18.0",
"v0.18.0-beta.2",
"v0.18.0-beta.1",
"v0.17.0",
"v0.17.0-beta.2",
"v0.17.0-beta.1",
"v0.16.0",
"v0.16.0-beta.1",
"v0.15.0",
"v0.15.0-beta.2",
"v0.15.0-beta.1",
"v0.14.0",
"v0.14.0-beta.1",
"v0.13.0",
"v0.13.0-beta.2",
"v0.13.0-beta.1",
"v0.12.0",
"v0.12.0-beta.2",
"v0.12.0-beta.1",
"v0.11.1",
"v0.11.0",
"v0.10.0",
"v0.9.0",
"v0.8.0",
"v0.7.5",
"v0.7.0",
"v0.6.0",
"v0.5.0",
"v0.4.0",
"v0.3.0",
"v0.2.5-beta.1",
"v0.2.0",
"v0.1.7",
"v0.1.6",
"v0.1.5",
"v0.1.4",
"v0.1.2",
"v0.1.1",
"v0.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-58766.json"
}
}
],
"modified": "2026-10-28T02:30:31.008575078Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/58xxx/CVE-2025-58766.json",
"https://github.com/dyad-sh/dyad/security/advisories/GHSA-7fxm-c5xx-7vpq",
"https://nvd.nist.gov/vuln/detail/CVE-2025-58766",
"https://github.com/dyad-sh/dyad/commit/1c0255ab126d3b38ae9e78b17cdab9a07e5f0185",
"https://github.com/dyad-sh/dyad/commit/ebcf89ee6cead83a33add5ef1e19c8d4f9b4ce9b"
],
"provider_metadata": {
"cwe_ids": [
"CWE-94"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/58xxx/CVE-2025-58766.json"
}
},
"related_cves": [
{
"value": "CVE-2025-58766",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 498066,
"published_at": "2025-09-17T17:36:22.811+00:00"
}