nodejs — security advisory
A privilege escalation vulnerability exists in Node.js <19.6.1, <18.14.1, <16.19.1 and <14.21.3 that made it possible to bypass the experimental Permissions (https://nodejs.org/api/permissions.html) feature in Node.js and access non authorized modules by using process.mainModule.require(). This only affects users who had enabled the experimental permissions option with --experimental-policy.
- Products
- nodejs
- Affected versions
- 18.13.0+dfsg1-1, 18.13.0+dfsg1-1.1, 18.19.0+dfsg-1, 18.19.0+dfsg-2, 18.19.0+dfsg-3, 18.19.0+dfsg-4, 18.19.0+dfsg-5
- Fixed versions
- 18.19.0+dfsg-2, 18.19.0+dfsg-6~deb12u1
- CVEs
- CVE-2023-23918
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 09:55 UTC · Revision 1
Source evidence
A privilege escalation vulnerability exists in Node.js <19.6.1, <18.14.1, <16.19.1 and <14.21.3 that made it possible to bypass the experimental Permissions (https://nodejs.org/api/permissions.html) feature in Node.js and access non authorized modules by using process.mainModule.require(). This only affects users who had enabled the experimental permissions option with --experimental-policy.
osv:DEBIAN-CVE-2023-23918
nodejs
Fixed versions: 18.19.0+dfsg-6~deb12u1
nodejs
Fixed versions: 18.19.0+dfsg-2
nodejs
Fixed versions: 18.19.0+dfsg-2
Complete source record
{
"id": "04ef2f61d3727c406d6c2df358abb6226e1d25813f6b19fff6201a176c708393",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-23918",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-23918",
"summary": "A privilege escalation vulnerability exists in Node.js <19.6.1, <18.14.1, <16.19.1 and <14.21.3 that made it possible to bypass the experimental Permissions (https://nodejs.org/api/permissions.html) feature in Node.js and access non authorized modules by using process.mainModule.require(). This only affects users who had enabled the experimental permissions option with --experimental-policy.",
"evidence": "osv:DEBIAN-CVE-2023-23918",
"products": [
{
"name": {
"value": "nodejs",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "18.19.0+dfsg-6~deb12u1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "18.13.0+dfsg1-1",
"evidence": "/affected/0/versions"
},
{
"value": "18.13.0+dfsg1-1.1",
"evidence": "/affected/0/versions"
},
{
"value": "18.19.0+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "18.19.0+dfsg-2",
"evidence": "/affected/0/versions"
},
{
"value": "18.19.0+dfsg-3",
"evidence": "/affected/0/versions"
},
{
"value": "18.19.0+dfsg-4",
"evidence": "/affected/0/versions"
},
{
"value": "18.19.0+dfsg-5",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "nodejs",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "18.19.0+dfsg-2",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "nodejs",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "18.19.0+dfsg-2",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2023-23918",
"aliases": [
"DEBIAN-CVE-2023-23918"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "18.19.0+dfsg-6~deb12u1"
}
]
}
],
"package": {
"name": "nodejs",
"purl": "pkg:deb/debian/nodejs?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"18.13.0+dfsg1-1",
"18.13.0+dfsg1-1.1",
"18.19.0+dfsg-1",
"18.19.0+dfsg-2",
"18.19.0+dfsg-3",
"18.19.0+dfsg-4",
"18.19.0+dfsg-5"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-23918.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "18.19.0+dfsg-2"
}
]
}
],
"package": {
"name": "nodejs",
"purl": "pkg:deb/debian/nodejs?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-23918.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "18.19.0+dfsg-2"
}
]
}
],
"package": {
"name": "nodejs",
"purl": "pkg:deb/debian/nodejs?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-23918.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-25T09:47:33.476627891Z",
"provider": "osv",
"upstream": [
"CVE-2023-23918"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-23918"
]
},
"related_cves": [
{
"value": "CVE-2023-23918",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 445279,
"published_at": "2023-02-23T20:15:13.92+00:00"
}