Apache APISIX: Openid-connect plugin Identity Header Spoofing
Insufficient Verification of Data Authenticity vulnerability in Apache APISIX. The openid-connect plugin under default configuration has an attack surface that allows the attacker to spoof identity headers allowing the attacker to get unauthorized access the protected resources. This issue affects Apache APISIX: from 2.3 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-44087
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 21:28 UTC · Revision 1
Source evidence
Apache APISIX: Openid-connect plugin Identity Header Spoofing
core-osv · Original sourcePublished 19 Jun 2026, 13:11 UTC
Insufficient Verification of Data Authenticity vulnerability in Apache APISIX. The openid-connect plugin under default configuration has an attack surface that allows the attacker to spoof identity headers allowing the attacker to get unauthorized access the protected resources. This issue affects Apache APISIX: from 2.3 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
osv:CVE-2026-44087
Complete source record
{
"id": "06c7b0e5012f7fabfc5e85ef120123813d9e7f9255afac16bc5a2eb665fcb1a4",
"url": "https://osv.dev/vulnerability/CVE-2026-44087",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache APISIX: Openid-connect plugin Identity Header Spoofing",
"summary": "Insufficient Verification of Data Authenticity vulnerability in Apache APISIX. The openid-connect plugin under default configuration has an attack surface that allows the attacker to spoof identity headers allowing the attacker to get unauthorized access the protected resources. This issue affects Apache APISIX: from 2.3 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.",
"evidence": "osv:CVE-2026-44087",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2026-44087",
"aliases": [
"BIT-apisix-2026-44087",
"CVE-2026-44087"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/apisix",
"type": "GIT",
"events": [
{
"introduced": "63f779aeae7a4cfdc3baa5c6dad955ef139719f8"
},
{
"fixed": "9ef2ecab67f652d38365049613610ef649bb4ad0"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.3"
},
{
"fixed": "3.17.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-44087.json"
}
}
],
"modified": "2026-10-28T02:30:23.677715580Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/44xxx/CVE-2026-44087.json",
"https://lists.apache.org/thread/72ryrgdssk6s2x9d6xn14bxyyl878xfm",
"https://nvd.nist.gov/vuln/detail/CVE-2026-44087"
],
"provider_metadata": {
"cwe_ids": [
"CWE-345"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "2.3"
},
{
"last_affected": "3.16.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/44xxx/CVE-2026-44087.json"
}
},
"related_cves": [
{
"value": "CVE-2026-44087",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 490235,
"published_at": "2026-06-19T13:11:17.219+00:00"
}