Medium
Guzzle OAuth Subscriber has insufficient nonce entropy
Type: advisorySources: OSV
Guzzle OAuth Subscriber signs Guzzle requests using OAuth 1.0. Prior to 0.8.1, Nonce generation does not use sufficient entropy nor a cryptographically secure pseudorandom source. This can leave servers vulnerable to replay attacks when TLS is not used. This vulnerability is fixed in 0.8.1.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-21617
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 04:08 UTC · Revision 1
Source evidence
Guzzle OAuth Subscriber has insufficient nonce entropy
core-osv · Original sourcePublished 6 Jan 2025, 19:23 UTC
Guzzle OAuth Subscriber signs Guzzle requests using OAuth 1.0. Prior to 0.8.1, Nonce generation does not use sufficient entropy nor a cryptographically secure pseudorandom source. This can leave servers vulnerable to replay attacks when TLS is not used. This vulnerability is fixed in 0.8.1.
osv:CVE-2025-21617
Complete source record
{
"id": "81976335412a00f464313134a4613cfa734ea8ceec76ae6af7f7a8126402db6a",
"url": "https://osv.dev/vulnerability/CVE-2025-21617",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Guzzle OAuth Subscriber has insufficient nonce entropy",
"summary": "Guzzle OAuth Subscriber signs Guzzle requests using OAuth 1.0. Prior to 0.8.1, Nonce generation does not use sufficient entropy nor a cryptographically secure pseudorandom source. This can leave servers vulnerable to replay attacks when TLS is not used. This vulnerability is fixed in 0.8.1.",
"evidence": "osv:CVE-2025-21617",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-21617",
"aliases": [
"CVE-2025-21617",
"GHSA-237r-r8m4-4q88"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/guzzle/oauth-subscriber",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "92b619b03bd21396e51c62e6bce83467d2ce8f53"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "0.8.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "92b619b03bd21396e51c62e6bce83467d2ce8f53"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "92b619b03bd21396e51c62e6bce83467d2ce8f53"
}
],
"source": "REFERENCES_TAG",
"original_tag": "0.8.1"
}
]
}
}
],
"versions": [
"0.8.0",
"0.7.0",
"0.6.0",
"0.5.0",
"0.4.0",
"0.3.0",
"0.2.0",
"0.1.2",
"0.1.1",
"0.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-21617.json"
}
}
],
"modified": "2026-10-28T02:30:26.083577388Z",
"provider": "osv",
"references": [
"https://github.com/guzzle/oauth-subscriber/blob/0.8.0/src/Oauth1.php#L192",
"https://github.com/guzzle/oauth-subscriber/releases/tag/0.8.1",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/21xxx/CVE-2025-21617.json",
"https://github.com/guzzle/oauth-subscriber/security/advisories/GHSA-237r-r8m4-4q88",
"https://nvd.nist.gov/vuln/detail/CVE-2025-21617",
"https://github.com/guzzle/oauth-subscriber/commit/92b619b03bd21396e51c62e6bce83467d2ce8f53"
],
"provider_metadata": {
"cwe_ids": [
"CWE-338"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/21xxx/CVE-2025-21617.json"
}
},
"related_cves": [
{
"value": "CVE-2025-21617",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 492392,
"published_at": "2025-01-06T19:23:23.232+00:00"
}