Security advisory
CouchDB administrative users can configure the database server via HTTP(S). Some of the configuration options include paths for operating system-level binaries that are subsequently launched by CouchDB. This allows an admin user in Apache CouchDB before 1.7.0 and 2.x before 2.1.1 to execute arbitrary shell commands as the CouchDB user, including downloading and executing scripts from the public internet.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2017-12636
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 07:24 UTC · Revision 1
Source evidence
CouchDB administrative users can configure the database server via HTTP(S). Some of the configuration options include paths for operating system-level binaries that are subsequently launched by CouchDB. This allows an admin user in Apache CouchDB before 1.7.0 and 2.x before 2.1.1 to execute arbitrary shell commands as the CouchDB user, including downloading and executing scripts from the public internet.
osv:CVE-2017-12636
Complete source record
{
"id": "e6a4c0e6b145eb98a9602d17ce54de44ca2e1401a44f2b6f0f124a3fdd6cc8dc",
"url": "https://osv.dev/vulnerability/CVE-2017-12636",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2017-12636",
"summary": "CouchDB administrative users can configure the database server via HTTP(S). Some of the configuration options include paths for operating system-level binaries that are subsequently launched by CouchDB. This allows an admin user in Apache CouchDB before 1.7.0 and 2.x before 2.1.1 to execute arbitrary shell commands as the CouchDB user, including downloading and executing scripts from the public internet.",
"evidence": "osv:CVE-2017-12636",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2017-12636",
"aliases": [
"CVE-2017-12636"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/couchdb",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "5f88da2a5ee8ba78917fafd572c7b9fa37e76460"
},
{
"introduced": "cb02b9b812174609403d67f60c314959388ba06c"
},
{
"last_affected": "41e529d1724883df6304bfd59937db0122d00082"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:couchdb:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.7.0"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:apache:couchdb:2.0.0:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.0.0"
},
{
"last_affected": "2.0.0"
}
],
"source": "CPE_STRING"
},
{
"cpe": "cpe:2.3:a:apache:couchdb:2.0.0:rc1:*:*:*:*:*:*",
"range": [
{
"introduced": "2.0.0-rc1"
},
{
"last_affected": "2.0.0-rc1"
}
],
"source": "CPE_STRING"
},
{
"cpe": "cpe:2.3:a:apache:couchdb:2.0.0:rc3:*:*:*:*:*:*",
"range": [
{
"introduced": "2.0.0-rc3"
},
{
"last_affected": "2.0.0-rc3"
}
],
"source": "CPE_STRING"
},
{
"cpe": "cpe:2.3:a:apache:couchdb:2.0.0:rc4:*:*:*:*:*:*",
"range": [
{
"introduced": "2.0.0-rc4"
},
{
"last_affected": "2.0.0-rc4"
}
],
"source": "CPE_STRING"
}
]
}
}
],
"versions": [
"2.0.0",
"2.0.0-rc1",
"2.0.0-rc3",
"2.0.0-rc4",
"2.0.0-RC4",
"2.0.0-RC3",
"2.0.0-RC1",
"1.6.1",
"1.6.0",
"fauxton"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-12636.json"
}
}
],
"modified": "2026-10-24T10:30:52.862733742Z",
"provider": "osv",
"references": [
"https://lists.apache.org/thread.html/6c405bf3f8358e6314076be9f48c89a2e0ddf00539906291ebdf0c67%40%3Cdev.couchdb.apache.org%3E",
"https://lists.debian.org/debian-lts-announce/2018/01/msg00026.html",
"https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbmu03935en_us",
"https://www.exploit-db.com/exploits/44913/",
"https://www.exploit-db.com/exploits/45019/",
"https://security.gentoo.org/glsa/201711-16"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:a:apache:couchdb:2.0.0:rc2:*:*:*:*:*:*"
],
"vendor_product": "apache:couchdb",
"extracted_events": [
{
"range": [
{
"introduced": "2.0.0-rc2"
},
{
"last_affected": "2.0.0-rc2"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2017-12636",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 437783,
"published_at": "2017-11-14T20:29:00.247+00:00"
}