High
No Rate Limiting on Login AUTH DB
Type: advisorySources: OSV
Flask-AppBuilder versions before 4.3.0 lack rate limiting which can allow an attacker to brute-force user credentials. Version 4.3.0 includes the ability to enable rate limiting using `AUTH_RATE_LIMITED = True`, `RATELIMIT_ENABLED = True`, and setting an `AUTH_RATE_LIMIT`.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-29005
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 6 Nov 2026, 09:28 UTC · Revision 1
Source evidence
Flask-AppBuilder versions before 4.3.0 lack rate limiting which can allow an attacker to brute-force user credentials. Version 4.3.0 includes the ability to enable rate limiting using `AUTH_RATE_LIMITED = True`, `RATELIMIT_ENABLED = True`, and setting an `AUTH_RATE_LIMIT`.
osv:CVE-2023-29005
Complete source record
{
"id": "b0d21875908581c6ca46ee69dfd90168e59aea0a247d95df1da8703392468d28",
"url": "https://osv.dev/vulnerability/CVE-2023-29005",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "No Rate Limiting on Login AUTH DB",
"summary": "Flask-AppBuilder versions before 4.3.0 lack rate limiting which can allow an attacker to brute-force user credentials. Version 4.3.0 includes the ability to enable rate limiting using `AUTH_RATE_LIMITED = True`, `RATELIMIT_ENABLED = True`, and setting an `AUTH_RATE_LIMIT`.",
"evidence": "osv:CVE-2023-29005",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2023-29005",
"aliases": [
"CVE-2023-29005",
"GHSA-9hcr-9hcv-x6pv",
"PYSEC-2026-1380"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/dpgaspar/flask-appbuilder",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "4554c40e2298d11c4472ca64b9a60236b12c6535"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "4.3.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:dpgaspar:flask-appbuilder:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "4.3.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v4.2.1",
"v4.2.0",
"v4.1.6",
"v4.1.5",
"v4.1.4",
"v4.1.3",
"v4.1.2",
"v4.1.1",
"v4.1.0",
"v4.0.0",
"v3.4.5",
"v3.4.4",
"v3.4.3",
"v3.4.2",
"v3.4.1",
"v3.4.0",
"v3.3.4",
"v3.3.3",
"v3.3.2",
"v3.3.1",
"v3.3.0",
"v3.2.3",
"v3.2.2",
"v3.2.1",
"v3.2.0",
"3.1.1",
"v3.1.1",
"v3.1.0",
"v3.0.1",
"v3.0.0",
"v2.3.4",
"v2.3.3",
"v2.3.2",
"v2.3.1",
"v2.3.0",
"v2.2.3",
"v2.2.2",
"v2.2.1",
"v2.2.1rc1",
"v2.2.0",
"v2.1.13",
"v2.1.12",
"v2.1.11",
"v2.1.10",
"v2.1.9",
"v2.1.8",
"v2.1.7",
"v2.1.6",
"v2.1.5",
"v2.1.4",
"v1.13.0",
"v2.1.3",
"v2.1.2",
"v2.1.1",
"v2.1.0",
"v2.0.0",
"v1.12.5",
"v1.12.4",
"v1.12.3",
"v1.12.2",
"v1.12.1",
"v1.9.6",
"v1.12.0",
"v1.11.1",
"v1.11.0",
"v1.10.0",
"v1.9.5",
"v1.9.4",
"v1.9.3",
"v1.9.2",
"v1.9.1",
"v1.9.0",
"v1.8.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-29005.json"
}
}
],
"modified": "2026-10-28T02:30:47.317024238Z",
"provider": "osv",
"references": [
"https://flask-limiter.readthedocs.io/en/stable/configuration.html",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/29xxx/CVE-2023-29005.json",
"https://github.com/dpgaspar/Flask-AppBuilder/security/advisories/GHSA-9hcr-9hcv-x6pv",
"https://nvd.nist.gov/vuln/detail/CVE-2023-29005"
],
"provider_metadata": {
"cwe_ids": [
"CWE-307"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/29xxx/CVE-2023-29005.json"
}
},
"related_cves": [
{
"value": "CVE-2023-29005",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 515079,
"published_at": "2023-04-10T20:47:17.958+00:00"
}