Medium
Security advisory
A persistent cross-site scripting (XSS) vulnerability in NexusPHP before 1.7.33 allows remote authenticated attackers to permanently inject arbitrary web script or HTML via the title parameter used in /subtitles.php.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-46889
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 23:32 UTC · Revision 1
Source evidence
A persistent cross-site scripting (XSS) vulnerability in NexusPHP before 1.7.33 allows remote authenticated attackers to permanently inject arbitrary web script or HTML via the title parameter used in /subtitles.php.
osv:CVE-2022-46889
Complete source record
{
"id": "1504876fa826aea6069ce1ac862ec2acd7261e51b28896b61f803f2f3a75f71a",
"url": "https://osv.dev/vulnerability/CVE-2022-46889",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2022-46889",
"summary": "A persistent cross-site scripting (XSS) vulnerability in NexusPHP before 1.7.33 allows remote authenticated attackers to permanently inject arbitrary web script or HTML via the title parameter used in /subtitles.php.",
"evidence": "osv:CVE-2022-46889",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2022-46889",
"aliases": [
"CVE-2022-46889"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/xiaomlove/nexusphp",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "a8c02858af97b7e635e5b491cfdd585ab5a034d4"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "1.7.33"
}
],
"source": "DESCRIPTION"
},
{
"range": [
{
"fixed": "a8c02858af97b7e635e5b491cfdd585ab5a034d4"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v1.7.33"
},
{
"cpe": "cpe:2.3:a:nexusphp:nexusphp:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.7.33"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v1.7.32",
"v1.7.31",
"v1.7.30",
"v1.7.28",
"v1.7.27",
"v1.7.24",
"v1.7.23",
"v1.7.21",
"v1.7.20",
"v1.7.19",
"v1.7.18",
"v1.7.17",
"v1.7.16",
"v1.7.15",
"v1.7.14",
"v1.7.13",
"v1.7.12",
"v1.7.11",
"v1.7.10",
"v1.7.9",
"v1.7.8",
"v1.7.7",
"v1.7.6",
"v1.7.5",
"v1.7.4",
"v1.7.3",
"v1.7.2",
"v1.7.1",
"v1.7.0",
"v1.6.5",
"v1.6.4",
"v1.6.3",
"v1.6.2",
"v1.6.1",
"v1.6.0",
"v1.6.0-beta14",
"v1.6.0-beta13",
"v1.6.0-beta12",
"v1.6.0-beta11",
"v1.6.0-beta10",
"v1.6.0-beta9",
"v1.6.0-beta8",
"v1.6.0-beta7",
"v1.6.0-beta6",
"v1.6.0-beta5",
"v1.6.0-beta4",
"v1.6.0-beta3",
"v1.6.0-beta2",
"v1.6.0-beta1",
"v1.5"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-46889.json"
}
}
],
"modified": "2026-10-28T02:30:40.484448094Z",
"provider": "osv",
"references": [
"https://github.com/xiaomlove/nexusphp/releases/tag/v1.7.33",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/46xxx/CVE-2022-46889.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-46889",
"https://www.surecloud.com/resources/blog/nexusphp-surecloud-security-review-identifies-authenticated-unauthenticated-vulnerabilities"
],
"provider_metadata": {
"cna_assigner": "mitre",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/46xxx/CVE-2022-46889.json"
}
},
"related_cves": [
{
"value": "CVE-2022-46889",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 507991,
"published_at": "2023-01-19T00:00:00+00:00"
}