PX4 Autopilot MAVLink FTP Session Validation Logic Error Allows Operations on Invalid File Descriptors
PX4 autopilot is a flight control solution for drones. Prior to 1.17.0-rc2, A logic error in the PX4 Autopilot MAVLink FTP session validation uses incorrect boolean logic (&& instead of ||), allowing BurstReadFile and WriteFile operations to proceed with invalid sessions or closed file descriptors. This enables an unauthenticated attacker to put the FTP subsystem into an inconsistent state, trigger operations on invalid file descriptors, and bypass session isolation checks. This vulnerability is fixed in 1.17.0-rc2.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-32713
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 19:16 UTC · Revision 1
Source evidence
PX4 Autopilot MAVLink FTP Session Validation Logic Error Allows Operations on Invalid File Descriptors
core-osv · Original sourcePublished 13 Mar 2026, 21:20 UTC
PX4 autopilot is a flight control solution for drones. Prior to 1.17.0-rc2, A logic error in the PX4 Autopilot MAVLink FTP session validation uses incorrect boolean logic (&& instead of ||), allowing BurstReadFile and WriteFile operations to proceed with invalid sessions or closed file descriptors. This enables an unauthenticated attacker to put the FTP subsystem into an inconsistent state, trigger operations on invalid file descriptors, and bypass session isolation checks. This vulnerability is fixed in 1.17.0-rc2.
osv:CVE-2026-32713
Complete source record
{
"id": "fc3a1430dad7131633463cafd67839ee86dd6a402edc4fed0bf6a407e18df97b",
"url": "https://osv.dev/vulnerability/CVE-2026-32713",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "PX4 Autopilot MAVLink FTP Session Validation Logic Error Allows Operations on Invalid File Descriptors",
"summary": "PX4 autopilot is a flight control solution for drones. Prior to 1.17.0-rc2, A logic error in the PX4 Autopilot MAVLink FTP session validation uses incorrect boolean logic (&& instead of ||), allowing BurstReadFile and WriteFile operations to proceed with invalid sessions or closed file descriptors. This enables an unauthenticated attacker to put the FTP subsystem into an inconsistent state, trigger operations on invalid file descriptors, and bypass session isolation checks. This vulnerability is fixed in 1.17.0-rc2.",
"evidence": "osv:CVE-2026-32713",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2026-32713",
"aliases": [
"CVE-2026-32713",
"GHSA-pp2c-jr5g-6f2m"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/px4/px4-autopilot",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "d6f12ad1c4f70ad3230afd7d86e971421e02fef4"
},
{
"introduced": "c2fb48990aacebc938c4e9998c7d5348f858fd22"
},
{
"last_affected": "61904bc14a9c34f5f87012410b5f473e074e55d8"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:dronecode:px4_drone_autopilot:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.17.0"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:dronecode:px4_drone_autopilot:1.17.0:alpha1:*:*:*:*:*:*",
"range": [
{
"introduced": "1.17.0-alpha1"
},
{
"last_affected": "1.17.0-alpha1"
}
],
"source": "CPE_STRING"
},
{
"cpe": "cpe:2.3:a:dronecode:px4_drone_autopilot:1.17.0:beta1:*:*:*:*:*:*",
"range": [
{
"introduced": "1.17.0-beta1"
},
{
"last_affected": "1.17.0-beta1"
}
],
"source": "CPE_STRING"
},
{
"cpe": "cpe:2.3:a:dronecode:px4_drone_autopilot:1.17.0:rc1:*:*:*:*:*:*",
"range": [
{
"introduced": "1.17.0-rc1"
},
{
"last_affected": "1.17.0-rc1"
}
],
"source": "CPE_STRING"
}
]
}
}
],
"versions": [
"1.17.0-alpha1",
"1.17.0-beta1",
"1.17.0-rc1",
"v1.17.0-rc1",
"v1.17.0-beta1",
"v1.17.0-alpha1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-32713.json"
}
}
],
"modified": "2026-10-28T02:30:51.486268394Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/32xxx/CVE-2026-32713.json",
"https://github.com/PX4/PX4-Autopilot/security/advisories/GHSA-pp2c-jr5g-6f2m",
"https://nvd.nist.gov/vuln/detail/CVE-2026-32713"
],
"provider_metadata": {
"cwe_ids": [
"CWE-670"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/32xxx/CVE-2026-32713.json"
}
},
"related_cves": [
{
"value": "CVE-2026-32713",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 520200,
"published_at": "2026-03-13T21:20:09.352+00:00"
}