containerd — security advisory
containerd is an open source container runtime. Before versions 1.6.18 and 1.5.18, when importing an OCI image, there was no limit on the number of bytes read for certain files. A maliciously crafted image with a large file where a limit was not applied could cause a denial of service. This bug has been fixed in containerd 1.6.18 and 1.5.18. Users should update to these versions to resolve the issue. As a workaround, ensure that only trusted images are used and that only trusted users have permissions to import images.
- Products
- containerd
- Affected versions
- Not specified
- Fixed versions
- 1.6.18~ds1-1
- CVEs
- CVE-2023-25153
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 15:26 UTC · Revision 1
Source evidence
containerd is an open source container runtime. Before versions 1.6.18 and 1.5.18, when importing an OCI image, there was no limit on the number of bytes read for certain files. A maliciously crafted image with a large file where a limit was not applied could cause a denial of service. This bug has been fixed in containerd 1.6.18 and 1.5.18. Users should update to these versions to resolve the issue. As a workaround, ensure that only trusted images are used and that only trusted users have permissions to import images.
osv:DEBIAN-CVE-2023-25153
containerd
Fixed versions: 1.6.18~ds1-1
containerd
Fixed versions: 1.6.18~ds1-1
containerd
Fixed versions: 1.6.18~ds1-1
Complete source record
{
"id": "ceaae62c6e085c093955ba802901a6576992d58c301f3ce0c71ad923874062cb",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-25153",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-25153",
"summary": "containerd is an open source container runtime. Before versions 1.6.18 and 1.5.18, when importing an OCI image, there was no limit on the number of bytes read for certain files. A maliciously crafted image with a large file where a limit was not applied could cause a denial of service. This bug has been fixed in containerd 1.6.18 and 1.5.18. Users should update to these versions to resolve the issue. As a workaround, ensure that only trusted images are used and that only trusted users have permissions to import images.",
"evidence": "osv:DEBIAN-CVE-2023-25153",
"products": [
{
"name": {
"value": "containerd",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.6.18~ds1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "containerd",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.6.18~ds1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "containerd",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.6.18~ds1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2023-25153",
"aliases": [
"DEBIAN-CVE-2023-25153"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.6.18~ds1-1"
}
]
}
],
"package": {
"name": "containerd",
"purl": "pkg:deb/debian/containerd?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-25153.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.6.18~ds1-1"
}
]
}
],
"package": {
"name": "containerd",
"purl": "pkg:deb/debian/containerd?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-25153.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.6.18~ds1-1"
}
]
}
],
"package": {
"name": "containerd",
"purl": "pkg:deb/debian/containerd?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-25153.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T18:00:35.984591920Z",
"provider": "osv",
"upstream": [
"CVE-2023-25153"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-25153"
]
},
"related_cves": [
{
"value": "CVE-2023-25153",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 455085,
"published_at": "2023-02-16T15:15:19.477+00:00"
}