axios 0.31.1 before 0.33.0 and 1.15.1 before 1.18.0 Denial of Service via maxDepth bypass
axios versions 0.31.1 before 0.33.0 and 1.15.1 before 1.18.0 contain an incomplete depth-limit bypass in toFormData.js when serializing objects with top-level keys ending in '{}'. Attackers who control object keys and nested values passed to axios form or parameter serialization can trigger a RangeError from JSON.stringify, causing denial of service in the affected request path.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-67321
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 13:55 UTC · Revision 1
Source evidence
axios 0.31.1 before 0.33.0 and 1.15.1 before 1.18.0 Denial of Service via maxDepth bypass
core-osv · Original sourcePublished 1 Aug 2026, 12:22 UTC
axios versions 0.31.1 before 0.33.0 and 1.15.1 before 1.18.0 contain an incomplete depth-limit bypass in toFormData.js when serializing objects with top-level keys ending in '{}'. Attackers who control object keys and nested values passed to axios form or parameter serialization can trigger a RangeError from JSON.stringify, causing denial of service in the affected request path.
osv:CVE-2026-67321
Complete source record
{
"id": "a01271b87dc66bd0abc5cca98a78ecf36122a388a105da0a87542f697389cc9d",
"url": "https://osv.dev/vulnerability/CVE-2026-67321",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "axios 0.31.1 before 0.33.0 and 1.15.1 before 1.18.0 Denial of Service via maxDepth bypass",
"summary": "axios versions 0.31.1 before 0.33.0 and 1.15.1 before 1.18.0 contain an incomplete depth-limit bypass in toFormData.js when serializing objects with top-level keys ending in '{}'. Attackers who control object keys and nested values passed to axios form or parameter serialization can trigger a RangeError from JSON.stringify, causing denial of service in the affected request path.",
"evidence": "osv:CVE-2026-67321",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2026-67321",
"aliases": [
"CVE-2026-67321",
"GHSA-hcpx-6fm6-wx23"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/axios/axios",
"type": "GIT",
"events": [
{
"introduced": "a589dc525af12e0fabef7d6e5be028ad433eee31"
},
{
"fixed": "d998cc9a1aa5cc45fbdfbdded6e9ecf8beb61aed"
},
{
"introduced": "ac42446be51300fe214ba3c6e40cc95f34fd6871"
},
{
"fixed": "2d06f96e8602c2db13b65a26340ee4a1bbc0b61f"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:axios:axios:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0.31.1"
},
{
"fixed": "0.33.0"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:axios:axios:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "1.15.1"
},
{
"fixed": "1.18.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v1.17.0",
"v1.16.1",
"v0.32.0",
"v0.31.1",
"v1.16.0",
"v1.15.2",
"v1.15.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-67321.json"
}
}
],
"modified": "2026-10-28T02:30:29.577615283Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/67xxx/CVE-2026-67321.json",
"https://github.com/axios/axios/security/advisories/GHSA-hcpx-6fm6-wx23",
"https://nvd.nist.gov/vuln/detail/CVE-2026-67321",
"https://www.vulncheck.com/advisories/axios-before-denial-of-service-via-maxdepth-bypass"
],
"provider_metadata": {
"cwe_ids": [
"CWE-674"
],
"cna_assigner": "VulnCheck",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/67xxx/CVE-2026-67321.json"
}
},
"related_cves": [
{
"value": "CVE-2026-67321",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 496113,
"published_at": "2026-08-01T12:22:18.177+00:00"
}