Skip to content
Heist/ feed
Back to feed
HighFix available

python-parsl — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2026-21892

Parsl is a Python parallel scripting library. A SQL Injection vulnerability exists in the parsl-visualize component of versions prior to 2026.01.05. The application constructs SQL queries using unsafe string formatting (Python % operator) with user-supplied input (workflow_id) directly from URL routes. This allows an unauthenticated attacker with access to the visualization dashboard to inject arbitrary SQL commands, potentially leading to data exfiltration or denial of service against the monitoring database. Version 2026.01.05 fixes the issue.

Products
python-parsl
Affected versions
2025.01.13+ds-1, 2025.01.13+ds-2, 2025.10.27-1, 2025.11.03+ds-1, 2025.11.10+ds-1, 2025.11.17+ds-1, 2025.12.01+ds-1, 2025.12.08+ds-1, 2025.12.15+ds-1
Fixed versions
2025.01.13+ds-1+deb13u1, 2026.01.05+ds-1
CVEs
CVE-2026-21892
Confirmed fixed CVEs
Not specified
Updated in this feed
28 Oct 2026, 03:40 UTC · Revision 1

Source evidence

DEBIAN-CVE-2026-21892

core-osv · Original source

Published 8 Jan 2026, 14:15 UTC

Parsl is a Python parallel scripting library. A SQL Injection vulnerability exists in the parsl-visualize component of versions prior to 2026.01.05. The application constructs SQL queries using unsafe string formatting (Python % operator) with user-supplied input (workflow_id) directly from URL routes. This allows an unauthenticated attacker with access to the visualization dashboard to inject arbitrary SQL commands, potentially leading to data exfiltration or denial of service against the monitoring database. Version 2026.01.05 fixes the issue.

osv:DEBIAN-CVE-2026-21892

python-parsl

Fixed versions: 2025.01.13+ds-1+deb13u1

python-parsl

Fixed versions: 2026.01.05+ds-1

Complete source record
{
  "id": "049b7c2528e79d713734a0ab68425336cc03823c9ad4a9d45992c1f72c3a4e96",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-21892",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2026-21892",
    "summary": "Parsl is a Python parallel scripting library. A SQL Injection vulnerability exists in the parsl-visualize component of versions prior to 2026.01.05. The application constructs SQL queries using unsafe string formatting (Python % operator) with user-supplied input (workflow_id) directly from URL routes. This allows an unauthenticated attacker with access to the visualization dashboard to inject arbitrary SQL commands, potentially leading to data exfiltration or denial of service against the monitoring database. Version 2026.01.05 fixes the issue.",
    "evidence": "osv:DEBIAN-CVE-2026-21892",
    "products": [
      {
        "name": {
          "value": "python-parsl",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2025.01.13+ds-1+deb13u1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": [
          {
            "value": "2025.01.13+ds-1",
            "evidence": "/affected/0/versions"
          }
        ]
      },
      {
        "name": {
          "value": "python-parsl",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2026.01.05+ds-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": [
          {
            "value": "2025.01.13+ds-1",
            "evidence": "/affected/1/versions"
          },
          {
            "value": "2025.01.13+ds-2",
            "evidence": "/affected/1/versions"
          },
          {
            "value": "2025.10.27-1",
            "evidence": "/affected/1/versions"
          },
          {
            "value": "2025.11.03+ds-1",
            "evidence": "/affected/1/versions"
          },
          {
            "value": "2025.11.10+ds-1",
            "evidence": "/affected/1/versions"
          },
          {
            "value": "2025.11.17+ds-1",
            "evidence": "/affected/1/versions"
          },
          {
            "value": "2025.12.01+ds-1",
            "evidence": "/affected/1/versions"
          },
          {
            "value": "2025.12.08+ds-1",
            "evidence": "/affected/1/versions"
          },
          {
            "value": "2025.12.15+ds-1",
            "evidence": "/affected/1/versions"
          }
        ]
      }
    ],
    "severity": "high",
    "structured": {
      "id": "DEBIAN-CVE-2026-21892",
      "aliases": [
        "DEBIAN-CVE-2026-21892"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2025.01.13+ds-1+deb13u1"
                }
              ]
            }
          ],
          "package": {
            "name": "python-parsl",
            "purl": "pkg:deb/debian/python-parsl?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "versions": [
            "2025.01.13+ds-1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-21892.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2026.01.05+ds-1"
                }
              ]
            }
          ],
          "package": {
            "name": "python-parsl",
            "purl": "pkg:deb/debian/python-parsl?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "versions": [
            "2025.01.13+ds-1",
            "2025.01.13+ds-2",
            "2025.10.27-1",
            "2025.11.03+ds-1",
            "2025.11.10+ds-1",
            "2025.11.17+ds-1",
            "2025.12.01+ds-1",
            "2025.12.08+ds-1",
            "2025.12.15+ds-1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-21892.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-07T09:47:34.086338294Z",
      "provider": "osv",
      "upstream": [
        "CVE-2026-21892"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2026-21892"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2026-21892",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 94661,
  "published_at": "2026-01-08T14:15:57.553+00:00"
}